summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Zacsh2021-11-25 23:41:39 -0600
committerJonathan Zacsh2021-11-25 23:41:39 -0600
commit9b032852f8b8b62e3fe08422f65176f1362149b6 (patch)
tree3216017a5c86633b25b52d8eb43c02dee9094901
parent09191baf8b03ace1e3f8fcc0783dd3ba92b65763 (diff)
downloadaur-9b032852f8b8b62e3fe08422f65176f1362149b6.tar.gz
noop~ish: nitpick audit since I'm forking the pkg
nitty details: - this is a bash script. always quote - consistency in spaces vs. tabs - pidcat upstream readme explicitly calls out its runtime dependency on `adb` (provided by `android-tools` package in arch): https://github.com/JakeWharton/pidcat/tree/0cb1c2c619eeed2c5b4cf05a123bf98992e60cd6#install - add my name as maintainer so previous maintainer isn't answerable for anything I do here. - per `man PKGBUILD` I'm updating to the latest upstream version (and I'm still not defining a `pkgver` func, as the default behavior of appending a commit is definitely needed: the `2.1.0` upstream git tag is SUPER old)
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb7171db5065..fe8d67d75dd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
-# Maintainer: Pedro Veloso <pedro.n.veloso at gmail dot com>
+# Maintainer: Jonathan Zacsh <j@zac.sh>
pkgname=pidcat-git
-pkgver=04.2017
+pkgver=2.1.0
pkgrel=1
pkgdesc="Pidcat is a colored logcat script with improved readability that only shows log entries for a specific Android package."
arch=('any')
url="https://github.com/JakeWharton/pidcat"
license=('Apache')
-depends=('python2')
+depends=(android-tools python2)
source=("git+$url.git" "pidcat.patch")
md5sums=('SKIP' "c9bfb27615710b5ddaaf74cef0042a17")
build() {
- patch -N ${srcdir}/pidcat/pidcat.py pidcat.patch
+ patch -N "$srcdir"/pidcat/pidcat.py pidcat.patch
}
package() {
# Install license
- install -Dm644 ${srcdir}/pidcat/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+ install -Dm644 "$srcdir"/pidcat/LICENSE.txt "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE.txt
# Install run script
- install -Dm755 ${srcdir}/pidcat/pidcat.py ${pkgdir}/usr/bin/pidcat
+ install -Dm755 "$srcdir"/pidcat/pidcat.py "$pkgdir"/usr/bin/pidcat
}