summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-09 02:18:51 -0300
committerHugo Osvaldo Barrera2015-06-09 02:18:51 -0300
commitc43a4edee4748a569ecf396b8f05f562bfe1c05d (patch)
treeb6af07101f948db9832ba77a15b8852674112d30
downloadaur-c43a4edee4748a569ecf396b8f05f562bfe1c05d.tar.gz
Initial commit.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0359c4bcda0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pidgin-gpg
+ pkgdesc = Transparently encrypts your instant messages with RSA encryption. Easy-to-use, but very secure.
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/segler-alex/pidgin-gpg
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = pidgin
+ source = git+https://git@github.com/segler-alex/Pidgin-GPG.git
+ md5sums = SKIP
+
+pkgname = pidgin-gpg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5118041828cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=pidgin-gpg
+_pkgname=Pidgin-GPG
+pkgver=latest
+pkgrel=1
+pkgdesc="Transparently encrypts your instant messages with RSA encryption. Easy-to-use, but very secure."
+arch=(i686 x86_64)
+url="https://github.com/segler-alex/pidgin-gpg"
+license=('unknown')
+depends=(pidgin)
+source=(git+https://git@github.com/segler-alex/Pidgin-GPG.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ autoreconf -i
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm 644 src/.libs/pidgin_gpg.so "$pkgdir/usr/lib/pidgin/pidgin_gpg.so"
+}