summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2017-07-18 09:56:56 -0400
committerSolomon Choina2017-07-18 09:56:56 -0400
commit8b171ebf4b31a2f52fa3ad56c9da45ca66623c34 (patch)
treea15f48f75971ecbdf2522f4fcd3e80d8618aadae
parent65d347dc7556c708eb1406d93d59bf88f9837208 (diff)
downloadaur-8b171ebf4b31a2f52fa3ad56c9da45ca66623c34.tar.gz
ported to meson
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c6d0637746e..2bad344ef76d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Apr 3 14:57:59 UTC 2017
+# Tue Jul 18 13:56:43 UTC 2017
pkgbase = pidgin-hg
pkgdesc = Multi-protocol instant messaging client. Latest mercurial build.
- pkgver = 3.r38247.107c6c2342ff
- pkgrel = 2
+ pkgver = 3.r38582.878de3ba891b
+ pkgrel = 1
url = http://pidgin.im/
arch = i686
arch = x86_64
@@ -35,6 +35,7 @@ pkgbase = pidgin-hg
makedepends = gplugin
makedepends = libx11
makedepends = python
+ makedepends = meson
options = !libtool
source = pidgin::hg+https://bitbucket.org/pidgin/main#branch=default
sha256sums = SKIP
@@ -71,7 +72,7 @@ pkgname = libpurple-hg
pkgname = finch-hg
pkgdesc = A ncurses-based messaging client
- depends = libpurple-hg=3.r38247.107c6c2342ff-2
+ depends = libpurple-hg=3.r38582.878de3ba891b-1
depends = libx11
depends = python2
provides = finch
diff --git a/PKGBUILD b/PKGBUILD
index 8fd453e4f4de..58b2a31e69cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=('pidgin-hg' 'libpurple-hg' 'finch-hg')
_hgname=pidgin
-pkgver=3.r38247.107c6c2342ff
-pkgrel=2
+pkgver=3.r38582.878de3ba891b
+pkgrel=1
pkgdesc="Multi-protocol instant messaging client. Latest mercurial build."
arch=('i686' 'x86_64')
url="http://pidgin.im/"
@@ -16,7 +16,7 @@ makedepends=('mercurial' 'python2' 'avahi' 'tk' 'ca-certificates' 'intltool'
'hicolor-icon-theme' 'dbus-glib' 'webkitgtk' 'json-glib'
'farstream' 'libsasl' 'libidn' 'dbus-glib' 'nss'
'libgnome-keyring' 'gplugin')
-makedepends+=('libx11' 'python')
+makedepends+=('libx11' 'python' 'meson')
options=('!libtool')
source=('pidgin::hg+https://bitbucket.org/pidgin/main#branch=default')
sha256sums=('SKIP')
@@ -28,21 +28,23 @@ pkgver() {
}
prepare() {
- cd "$srcdir"/$_hgname
+ cd "$srcdir"/"$_hgname"
+ rm -rf ../build
+ mkdir ../build
+ NOCONFIGURE=1 ./autogen.sh
+
- ./autogen.sh \
- --prefix=/usr \
+build() {
+ cd "$srcdir"/build
+ meson --prefix=/usr \ --builtype=release ../${_hgname}
--sysconfdir=/etc \
--disable-meanwhile \
- --disable-gnutls \
--enable-cyrus-sasl \
--disable-kwallet \
--with-python=/usr/bin/python \
--with-system-ssl-certs=/etc/ssl/certs
-}
-
-build() {
- cd "$srcdir"/$_hgname
+ ninja
+ }
make
}