summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2019-01-24 07:46:40 -0500
committerSolomon Choina2019-01-24 07:46:40 -0500
commita8b26380f8a57783614c8b914657144e61e0721e (patch)
tree80ccc92d61e8f9cd8208066c4d56f83b486988df
parent48fc0af8208274addb6997fe125b47785feabee8 (diff)
downloadaur-a8b26380f8a57783614c8b914657144e61e0721e.tar.gz
adding dependcies and updates
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f36d1c97d66..551f1596b2b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pidgin-hg
pkgdesc = Multi-protocol instant messaging client. Latest mercurial build.
- pkgver = 3.r38930.fdf18345ddf3
+ pkgver = 3.r39416.b117963f4ff8
pkgrel = 1
url = http://pidgin.im/
arch = i686
@@ -26,6 +26,7 @@ pkgbase = pidgin-hg
makedepends = json-glib
makedepends = farstream
makedepends = libsasl
+ makedepends = gtk-doc
makedepends = libidn
makedepends = dbus-glib
makedepends = nss
@@ -34,6 +35,8 @@ pkgbase = pidgin-hg
makedepends = libx11
makedepends = meson
depends = enchant1.6
+ depends = libgadu
+ depends = talkatu-hg
depends = meanwhile
depends = farstream
depends = libsasl
diff --git a/PKGBUILD b/PKGBUILD
index b6e5b00ee132..4cfe21bf6fdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=('pidgin-hg') #'libpurple-hg' 'finch-hg')
_hgname=pidgin
-pkgver=3.r38930.fdf18345ddf3
+pkgver=3.r39416.b117963f4ff8
pkgrel=1
provides=("pidgin" "libpurple" "finch")
conflicts=("pidgin" "libpurple" "finch")
@@ -12,7 +12,7 @@ pkgdesc="Multi-protocol instant messaging client. Latest mercurial build."
arch=('i686' 'x86_64')
url="http://pidgin.im/"
license=('GPL')
-depends=('enchant1.6' 'meanwhile' 'farstream' 'libsasl' 'libidn' 'dbus-glib' 'nss'
+depends=('enchant1.6' 'libgadu' 'talkatu-hg' 'meanwhile' 'farstream' 'libsasl' 'libidn' 'dbus-glib' 'nss'
'libgnome-keyring' 'startup-notification' 'gtkspell' 'libxss' 'libsm'
'hicolor-icon-theme' 'dbus-glib' 'webkitgtk' 'json-glib')
optdepends=('avahi: Bonjour protocol support'
@@ -24,7 +24,7 @@ makedepends=('mercurial' 'python2' 'avahi' 'tk' 'ca-certificates' 'intltool'
'tk' 'ca-certificates' 'intltool' 'networkmanager'
'startup-notification' 'gtkspell' 'libxss' 'libsm'
'hicolor-icon-theme' 'dbus-glib' 'webkitgtk' 'json-glib'
- 'farstream' 'libsasl' 'libidn' 'dbus-glib' 'nss'
+ 'farstream' 'libsasl' 'gtk-doc' 'libidn' 'dbus-glib' 'nss'
'libgnome-keyring' 'gplugin')
makedepends+=('libx11' 'meson')
options=('!libtool')
@@ -39,7 +39,7 @@ pkgver() {
build() {
cd "$srcdir"/pidgin
- arch-meson build -Dsilc=false
+ arch-meson build -Dsilc=false -Ddoc=true
ninja -C build
}