summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Gross2017-02-26 21:22:43 -0500
committerJustin Gross2017-02-26 21:22:43 -0500
commite4e12946c6774b6644a2aece2517e68f534d273d (patch)
tree7de6a75322ab8d09a0559e236f7d2820bef9dd04
downloadaur-e4e12946c6774b6644a2aece2517e68f534d273d.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD33
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..487b1308accd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = pidgin-mam-git
+ pkgdesc = Pidgin with Message Archive Management support
+ pkgver = 2.11.0.1.r1.g3f338ce
+ pkgrel = 1
+ url = https://github.com/CkNoSFeRaTU/pidgin
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = libpurple
+ depends = startup-notification
+ depends = gtkspell
+ depends = libxss
+ depends = libsm
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = hicolor-icon-theme
+ optdepends = aspell: for spelling correction
+ provides = pidgin
+ conflicts = pidgin
+ source = pidgin-mam-git::git+https://github.com/CkNoSFeRaTU/pidgin
+ md5sums = SKIP
+
+pkgname = pidgin-mam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..885bd204568e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Justin Gross <jgross.biz@gmail.com>
+
+pkgname=pidgin-mam-git
+pkgver=2.11.0.1.r1.g3f338ce
+pkgrel=1
+pkgdesc="Pidgin with Message Archive Management support"
+arch=(i686 x86_64)
+url="https://github.com/CkNoSFeRaTU/pidgin"
+license=('GPL2')
+depends=('libpurple' 'startup-notification' 'gtkspell' 'libxss' 'libsm' 'gst-plugins-base' 'gst-plugins-good' 'hicolor-icon-theme')
+optdepends=('aspell: for spelling correction')
+makedepends=('git')
+conflicts=('pidgin')
+provides=('pidgin')
+source=("pidgin-mam-git::git+https://github.com/CkNoSFeRaTU/pidgin")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ autoreconf -f -i
+ ./configure --disable-meanwhile --disable-tk --enable-gnutls=yes
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
+}