summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-16 02:10:25 -0600
committerBrian Bidulock2015-07-16 02:10:25 -0600
commitb72b50dafa31879b9a68b4736447d14039775975 (patch)
treee0de569edaaa09580e7fe0dd45b9117bb3081c61
downloadaur-b72b50dafa31879b9a68b4736447d14039775975.tar.gz
initial version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD53
-rw-r--r--piedock-libpng16.patch22
-rw-r--r--piedock.desktop7
-rw-r--r--piedock.install18
5 files changed, 121 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc85694b925a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = piedock
+ pkgdesc = A task bar and application launcher in shape of a circular pie menu.
+ pkgver = 1.6.3
+ pkgrel = 2
+ url = http://www.markusfisch.de/
+ install = piedock.install
+ arch = i686
+ arch = x86_64
+ license = custom:MIT
+ depends = libxft
+ depends = libxmu
+ optdepends = gnome-icon-theme: default icons
+ source = http://www.markusfisch.de/downloads/piedock-1.6.3.tar.bz2
+ source = piedock.desktop
+ source = piedock-libpng16.patch
+ sha256sums = 252e58bb36122e09aafbd9297b2d17054e60d548d21fb548e53317ca03180be9
+ sha256sums = 3b1b6e248eecf4591eb0502e914a79e2449e405655fe1f54c8f593b1b6cbcfe4
+ sha256sums = 9e86635ba37a77d0e1e1814b3cd6dd86be7c30a4b1f1888f50688d0eafadc370
+
+pkgname = piedock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbfbc174596c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: speps <speps at aur dot archlinux dot org>
+
+pkgname=piedock
+pkgver=1.6.3
+pkgrel=2
+pkgdesc="A task bar and application launcher in shape of a circular pie menu."
+arch=(i686 x86_64)
+url="http://www.markusfisch.de/"
+license=('custom:MIT')
+depends=('libxft' 'libxmu')
+optdepends=('gnome-icon-theme: default icons')
+install="$pkgname.install"
+source=("${url}downloads/$pkgname-$pkgver.tar.bz2"
+ "$pkgname.desktop"
+ "$pkgname-libpng16.patch")
+sha256sums=('252e58bb36122e09aafbd9297b2d17054e60d548d21fb548e53317ca03180be9'
+ '3b1b6e248eecf4591eb0502e914a79e2449e405655fe1f54c8f593b1b6cbcfe4'
+ '9e86635ba37a77d0e1e1814b3cd6dd86be7c30a4b1f1888f50688d0eafadc370')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # libpng 1.6 support
+ patch -p0 < ../piedock-libpng16.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+
+ # configuration file
+ install -Dm644 res/${pkgname}rc.sample \
+ "$pkgdir/usr/share/$pkgname/${pkgname}rc.sample"
+
+ # additional icons
+ cp -a res/window-control \
+ "$pkgdir/usr/share/$pkgname"
+
+ # desktop file
+ install -Dm644 ../$pkgname.desktop \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ # license
+ install -Dm644 COPYING \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/piedock-libpng16.patch b/piedock-libpng16.patch
new file mode 100644
index 000000000000..2f0d5c69b745
--- /dev/null
+++ b/piedock-libpng16.patch
@@ -0,0 +1,22 @@
+--- src/IconMap.cpp 2013-10-07 04:56:43.000000000 +1030
++++ src/IconMap.cpp 2014-01-12 10:22:14.746162850 +1030
+@@ -15,7 +15,7 @@
+ #include "WildcardCompare.h"
+ #include "Png.h"
+
+-#include <string>
++#include "string.h"
+ #include <algorithm>
+ #include <sstream>
+ #include <fstream>
+--- src/Png.cpp 2013-10-07 04:56:43.000000000 +1030
++++ src/Png.cpp 2014-01-12 10:22:27.602994831 +1030
+@@ -13,7 +13,7 @@
+ */
+ #include "Png.h"
+
+-#include <string>
++#include "string.h"
+ #include <fstream>
+ #include <stdexcept>
+
diff --git a/piedock.desktop b/piedock.desktop
new file mode 100644
index 000000000000..895ea5e01e34
--- /dev/null
+++ b/piedock.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Pie Dock
+Comment=A Circular Menu
+Exec=piedock
+Icon=emblem-new
+Categories=GNOME;Utility;
diff --git a/piedock.install b/piedock.install
new file mode 100644
index 000000000000..fa8d3ae6dd99
--- /dev/null
+++ b/piedock.install
@@ -0,0 +1,18 @@
+post_install() {
+ update-desktop-database -q
+ cat << EOF
+
+>>> To run PieDock, you have to copy and edit a sample configuration file in your home folder
+>>>
+>>> $ cp /usr/share/piedock/piedockrc.sample ~/.piedockrc
+
+EOF
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}