summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2020-03-23 13:23:39 +0000
committerOmar Pakker2020-03-23 13:23:39 +0000
commit8b167be0b830fcd2b55cf547b57306784f1bb5e4 (patch)
tree2edc8c14f75f014cabb4c16cf0714cfceefdbc79
parent1f89761a615e7e5a9791f6835aca13f5c27d6f04 (diff)
downloadaur-8b167be0b830fcd2b55cf547b57306784f1bb5e4.tar.gz
Update deps and URLs
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 982a4b00ceb8..ae8240207e87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = piglit-git
pkgdesc = OpenGL implementation testing suite. Provides a simple means to perform regression tests.
- pkgver = r9890.827d37435
- pkgrel = 2
+ pkgver = r10943.cdb765a36
+ pkgrel = 1
url = http://piglit.freedesktop.org/
install = piglit.install
arch = i686
@@ -11,11 +11,10 @@ pkgbase = piglit-git
license = LGPL2.1
makedepends = git
makedepends = cmake
- makedepends = glproto
+ makedepends = xorgproto
depends = waffle
depends = python-mako
depends = python-numpy
- depends = python-six
depends = libxrender
depends = glu
depends = libcaca
@@ -23,10 +22,11 @@ pkgbase = piglit-git
optdepends = python-lxml: Accelerated python XML library using libxml2
optdepends = python-simplejson: Fast implementation of the python JSON library
optdepends = python-jsonstreams: A JSON stream writer for python
+ optdepends = vkrunner: Vulkan shader script testing
provides = piglit
conflicts = piglit
options = !emptydirs
- source = git://anongit.freedesktop.org/piglit
+ source = git+https://gitlab.freedesktop.org/mesa/piglit.git
sha256sums = SKIP
pkgname = piglit-git
diff --git a/PKGBUILD b/PKGBUILD
index d71935155ec2..81c027f28ac9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,23 @@
_pkgname="piglit"
pkgname="${_pkgname}-git"
-pkgver=r9890.827d37435
-pkgrel=2
+pkgver=r10943.cdb765a36
+pkgrel=1
pkgdesc="OpenGL implementation testing suite. Provides a simple means to perform regression tests."
arch=('i686' 'x86_64')
url="http://piglit.freedesktop.org/"
license=('GPL2' 'GPL3' 'LGPL2.1')
-depends=('waffle' 'python-mako' 'python-numpy' 'python-six' 'libxrender' 'glu' 'libcaca' 'libxkbcommon')
+depends=('waffle' 'python-mako' 'python-numpy' 'libxrender' 'glu' 'libcaca' 'libxkbcommon')
optdepends=('python-lxml: Accelerated python XML library using libxml2'
'python-simplejson: Fast implementation of the python JSON library'
- 'python-jsonstreams: A JSON stream writer for python')
-makedepends=('git' 'cmake' 'glproto')
+ 'python-jsonstreams: A JSON stream writer for python'
+ 'vkrunner: Vulkan shader script testing')
+makedepends=('git' 'cmake' 'xorgproto')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
options=('!emptydirs')
install="${_pkgname}.install"
-source=("git://anongit.freedesktop.org/piglit")
+source=("git+https://gitlab.freedesktop.org/mesa/piglit.git")
sha256sums=('SKIP')
pkgver() {
@@ -27,7 +28,10 @@ pkgver() {
build() {
cd "${_pkgname}"
- cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ .
make
}