summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2016-05-21 19:03:49 +0200
committerOmar Pakker2016-05-21 19:03:49 +0200
commitd874cf3f0558ff7e8d9231ba3f5042ac95884aa0 (patch)
tree4a358d723884868a011ff93ecb1c29e21e06599a
downloadaur-d874cf3f0558ff7e8d9231ba3f5042ac95884aa0.tar.gz
Initial PKGBUILD for piglit.
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD44
-rw-r--r--piglit.install10
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..577c9debdeeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = piglit-git
+ pkgdesc = OpenGL implementation testing suite. Provides a simple means to perform regression tests.
+ pkgver = r8676.4d667d4
+ pkgrel = 1
+ url = http://piglit.freedesktop.org/
+ install = piglit.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ license = LGPL2.1
+ makedepends = git
+ makedepends = cmake
+ makedepends = glproto
+ depends = waffle
+ depends = python-mako
+ depends = python-numpy
+ depends = python-six
+ depends = libxrender
+ depends = glu
+ depends = libcaca
+ optdepends = python-lxml: Accelerated python XML library using libxml2
+ optdepends = python-simplejson: Fast implementation of the python JSON library
+ provides = piglit
+ conflicts = piglit
+ options = !emptydirs
+ source = git://anongit.freedesktop.org/piglit
+ sha256sums = SKIP
+
+pkgname = piglit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1341793bf9ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Omar Pakker <omar.pakker@oracle.com>
+
+pkgname=piglit-git
+pkgver=r8676.4d667d4
+pkgrel=1
+pkgdesc="OpenGL implementation testing suite. Provides a simple means to perform regression tests."
+arch=('i686' 'x86_64')
+url="http://piglit.freedesktop.org/"
+license=('GPL2' 'GPL3' 'LGPL2.1')
+depends=('waffle' 'python-mako' 'python-numpy' 'python-six' 'libxrender' 'glu' 'libcaca')
+optdepends=('python-lxml: Accelerated python XML library using libxml2'
+ 'python-simplejson: Fast implementation of the python JSON library')
+makedepends=('git' 'cmake' 'glproto')
+provides=('piglit')
+conflicts=('piglit')
+options=('!emptydirs')
+install=piglit.install
+changelog=
+source=("git://anongit.freedesktop.org/piglit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/piglit"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/piglit"
+
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr .
+
+ make
+}
+
+package() {
+ cd "${srcdir}/piglit"
+
+ make DESTDIR="${pkgdir}/" install
+
+ cd "${pkgdir}/usr/lib/piglit/lib/"
+ find . -name "*.so" -exec ln -s '{}' "../../{}" \;
+}
+
diff --git a/piglit.install b/piglit.install
new file mode 100644
index 000000000000..f87d644979e4
--- /dev/null
+++ b/piglit.install
@@ -0,0 +1,10 @@
+
+post_install() {
+ echo 'While you can run piglit on released mesa versions, it's much more useful to see results on the latest and greatest.'
+ echo 'Install mesa-git from the AUR to get the latest version.'
+}
+
+post_upgrade() {
+ post_install
+}
+