summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2017-03-18 13:50:03 +0200
committervlad2017-03-18 13:50:03 +0200
commit8fc396af04a743c5f1dae85c884facaed9314f6d (patch)
treec1fe21fed3f72e5d897fd959fc6d308fe1539820
downloadaur-8fc396af04a743c5f1dae85c884facaed9314f6d.tar.gz
add pijul
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67ee66b7f618
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pijul
+ pkgdesc = Version control system based on a theory of patches
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://pijul.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cargo
+ source = https://pijul.org/releases/pijul-0.3.tar.gz
+ sha256sums = 2c7b354b4ab142ac50a85d70c80949ff864377b37727b862d103d3407e2c7818
+
+pkgname = pijul
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d46f7080376
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Vlad M. <vlad@archlinux.net>
+
+pkgname=pijul
+pkgver=0.3
+pkgrel=1
+pkgdesc="Version control system based on a theory of patches"
+url='https://pijul.org'
+makedepends=('cargo')
+arch=('i686' 'x86_64')
+license=('GPL')
+source=("$url/releases/$pkgname-$pkgver.tar.gz")
+sha256sums=('2c7b354b4ab142ac50a85d70c80949ff864377b37727b862d103d3407e2c7818')
+
+build() {
+ cd "$pkgname/$pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname/$pkgname"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}