summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2022-11-26 21:29:44 +0100
committeractionless2022-11-26 21:29:44 +0100
commit03e355a6a88f198fea46c9f8bb4ab8b80200cba7 (patch)
treec69b871ba3882b48609e7d26e0b4bf86dcf3cffd
parenteaf072967ab26a25c4433ab6e7e5936cde4a7f7c (diff)
downloadaur-03e355a6a88f198fea46c9f8bb4ab8b80200cba7.tar.gz
update to 1.14.3
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG8
-rw-r--r--PKGBUILD5
3 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c67e077f51f..fed249d5c12d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pikaur
pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
- pkgver = 1.14.2
+ pkgver = 1.14.3
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
@@ -8,6 +8,7 @@ pkgbase = pikaur
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-markdown-it-py
depends = pyalpm
depends = git
@@ -16,7 +17,7 @@ pkgbase = pikaur
optdepends = python-defusedxml: securely wrap Arch news replies
provides = pikaur
conflicts = pikaur-git
- source = pikaur-1.14.2.tar.gz::https://github.com/actionless/pikaur/archive/1.14.2.tar.gz
- b2sums = 0f6e8bc0178442523004f43088c0108ca23fa4fa9be34637e680ec95035797dc66e008482c9dc74fa4f57d4e9e7b2499ff6bc2b4fe9ae9d337ad6429b33cb7ae
+ source = pikaur-1.14.3.tar.gz::https://github.com/actionless/pikaur/archive/1.14.3.tar.gz
+ b2sums = a78d893ae94466e159044867be029a8fddea72104887291c44a9293a1456609a0579ce2c6c0d267fce98e9abe15823727f63eb6050db6008448940f98d732755
pkgname = pikaur
diff --git a/CHANGELOG b/CHANGELOG
index ecad0c9bca7d..9e1fbd1f50d7 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1972,3 +1972,11 @@ Sat Nov 26 08:31:02 2022 +0100
2022-11-26 2bdb925 actionless fix(pprint: create_debug_logger): use `X is not None` except of `not X`
2022-11-26 a50ae21 actionless fix(main: OutputEncodingWrapper): reraise exception before stderr closes
2022-11-26 a8f3af6 actionless fix(InstallInfoFetcher: get_repo_pkgs_info): correctly determine if pkg already processed
+
+
+Sat Nov 26 21:27:02 2022 +0100
+-------------------------------------------------
+1.14.3 Hotfix release 1.14.3
+
+ 2022-11-26 376b3cc actionless chore(pkgbuild): fix dep chain problem
+ with python-pep517
diff --git a/PKGBUILD b/PKGBUILD
index 6fb7e8f51826..5a7960a6bbe4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.14.2
+pkgver=1.14.3
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -11,7 +11,7 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-b2sums=('0f6e8bc0178442523004f43088c0108ca23fa4fa9be34637e680ec95035797dc66e008482c9dc74fa4f57d4e9e7b2499ff6bc2b4fe9ae9d337ad6429b33cb7ae')
+b2sums=('a78d893ae94466e159044867be029a8fddea72104887291c44a9293a1456609a0579ce2c6c0d267fce98e9abe15823727f63eb6050db6008448940f98d732755')
depends=(
'pyalpm'
'git'
@@ -20,6 +20,7 @@ makedepends=(
'python-wheel'
'python-build'
'python-installer'
+ 'python-setuptools' # i think it normally should be required by python-pep517 which required by python-build/installer
'python-markdown-it-py'
)
optdepends=(