summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2018-09-03 04:01:55 +0200
committeractionless2018-09-03 04:01:55 +0200
commit5c7af2a7ba6b4b1cf7a6564b16d4a6b6499bfda9 (patch)
tree51749c3192215898d3def1cdd486f8cdbad312b3
parentcd522fbebb70c67e8ab8d6f8b1d04daea970351b (diff)
downloadaur-5c7af2a7ba6b4b1cf7a6564b16d4a6b6499bfda9.tar.gz
update to 1.2.24
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG11
-rw-r--r--PKGBUILD6
3 files changed, 18 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a89f6f42f9..92ec03d8b4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pikaur
- pkgdesc = AUR helper with minimal dependencies inspired by pacaur, yaourt and yay. Review PKGBUILDs all in once, next build them all without user interaction.
- pkgver = 1.2.23
+ pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
+ pkgver = 1.2.24
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
@@ -10,8 +10,8 @@ pkgbase = pikaur
depends = git
optdepends = asp: for ABS support in -G/--getpkgbuild operation
conflicts = pikaur-git
- source = pikaur-1.2.23.tar.gz::https://github.com/actionless/pikaur/archive/1.2.23.tar.gz
- md5sums = e8547b786cd77040ac46f49463089d8e
+ source = pikaur-1.2.24.tar.gz::https://github.com/actionless/pikaur/archive/1.2.24.tar.gz
+ md5sums = f86445ed1a4fe047e566d63264a6a260
pkgname = pikaur
diff --git a/CHANGELOG b/CHANGELOG
index d93ccf67ad6..837adb427a5 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -672,3 +672,14 @@ Wed Aug 22 13:06:13 2018 +0200
1.2.23 Bugfix release 1.2.23:
2018-08-22 35be8fb actionless fix(prompt): don't use printlock when print answer in requireenterconfirm=no prompt
+
+
+Mon Sep 3 04:00:42 2018 +0200
+-------------------------------------------------
+1.2.24 Release 1.2.24:
+
+ Notable changes:
+ 2018-08-30 724d5d9 fix(main: handle_sig_int): skip printlock
+ 2018-08-30 3875b24 fix(main: handle_sig_int): use SysExit exception instead of sys.exit()
+ 2018-08-24 61b23f7 fix(install info fetcher: mark_dependant): package got marked as provider as mistake
+ 2018-08-22 a98a19d fix(pacman: install built deps): stop if there are no deps to install
diff --git a/PKGBUILD b/PKGBUILD
index 60174e2b58c..de87f7768f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.2.23
+pkgver=1.2.24
pkgrel=1
-pkgdesc="AUR helper with minimal dependencies inspired by pacaur, yaourt and yay. Review PKGBUILDs all in once, next build them all without user interaction."
+pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
url="https://github.com/actionless/pikaur"
license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-md5sums=('e8547b786cd77040ac46f49463089d8e')
+md5sums=('f86445ed1a4fe047e566d63264a6a260')
depends=(
'pacman'
'pyalpm'