summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2023-05-26 04:43:33 +0200
committeractionless2023-05-26 04:43:33 +0200
commit610e44fd0d45b6351f2b472301ad797be08a350f (patch)
treec23b435e813f418469d4da2b4208a490be65e059
parent8b559067122d39abd82da4326879ddddea81e85d (diff)
downloadaur-610e44fd0d45b6351f2b472301ad797be08a350f.tar.gz
update to 1.15.3
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG10
-rw-r--r--PKGBUILD5
3 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 523fe7044d91..0e521c5392cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = pikaur
pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
- pkgver = 1.15.2
+ pkgver = 1.15.3
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
license = GPL3
makedepends = python-wheel
+ makedepends = python-hatchling
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
@@ -17,7 +18,7 @@ pkgbase = pikaur
optdepends = python-defusedxml: securely wrap Arch news replies
provides = pikaur
conflicts = pikaur-git
- source = pikaur-1.15.2.tar.gz::https://github.com/actionless/pikaur/archive/1.15.2.tar.gz
- b2sums = 66eb7f42b0f51696f8629ea4994e6160326b2defce0899737d9915f26138a27160c38a5499c6145d904a094d9120830ffadde5631a33239b4a9730b9affee2f4
+ source = pikaur-1.15.3.tar.gz::https://github.com/actionless/pikaur/archive/1.15.3.tar.gz
+ b2sums = c8779c2bac120cd619853f7961824f96fe593bbccf020629e8e7babcbb67b1e35a9e18bbc55c14d4b9eb33bbcab491329e0f0391c7a066c0e79cca59456acac1
pkgname = pikaur
diff --git a/CHANGELOG b/CHANGELOG
index 0b071b0d23dc..3b4297509ed1 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -2073,3 +2073,13 @@ Sun May 21 23:29:18 2023 +0200
* 2023-05-21 109d71d actionless refactor: switch from `asp` to `devtools`
* 2023-05-16 388802a actionless chore(pacman: official_repos): add new repo names
* 2023-05-06 117dc32 Bundy01 chore(locale): update es.po and fr.po (#714)
+
+
+Fri May 26 04:41:58 2023 +0200
+-------------------------------------------------
+1.15.3 Release 1.15.3
+
+ Notables changes:
+ * 2023-05-26 4620ade actionless fix(getpkgbuild_cli): --unprivileged was renamed to --protocol=https in `devtools`
+ * 2023-05-26 810efe4 actionless fix(pkgbuild): add python-hatchling
+ * 2023-05-23 2faea6e Curtis Lee Bolin chore(packaging): copy metadata from `setup.py` to `pyproject.toml` (#716)
diff --git a/PKGBUILD b/PKGBUILD
index e3c1896e1fc4..5fe35f0c763a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.15.2
+pkgver=1.15.3
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -11,13 +11,14 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-b2sums=('66eb7f42b0f51696f8629ea4994e6160326b2defce0899737d9915f26138a27160c38a5499c6145d904a094d9120830ffadde5631a33239b4a9730b9affee2f4')
+b2sums=('c8779c2bac120cd619853f7961824f96fe593bbccf020629e8e7babcbb67b1e35a9e18bbc55c14d4b9eb33bbcab491329e0f0391c7a066c0e79cca59456acac1')
depends=(
'pyalpm'
'git'
)
makedepends=(
'python-wheel'
+ 'python-hatchling'
'python-build'
'python-installer'
'python-setuptools' # i think it normally should be required by python-pep517 which required by python-build/installer