summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2018-03-25 00:54:19 +0100
committeractionless2018-03-25 00:58:28 +0100
commit8f7134f454dcd84041e9dbf6a80c8f9acc5f4bc3 (patch)
tree50e4587e7b38737ba13e27cc135c34cd4f8c05e5
downloadaur-8f7134f454dcd84041e9dbf6a80c8f9acc5f4bc3.tar.gz
update to 0.9.1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e87af5c4eb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pikaur
+ pkgdesc = AUR helper with minimal dependencies. Review PKGBUILDs all in once, next build them all without user interaction.
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://github.com/actionless/pikaur
+ arch = any
+ license = GPLv3
+ depends = pyalpm
+ depends = python-setuptools
+ depends = git
+ depends = sudo
+ depends = fakeroot
+ conflicts = pikaur-git
+ source = pikaur-0.9.1.tar.gz::https://github.com/actionless/pikaur/archive/0.9.1.tar.gz
+ md5sums = SKIP
+
+pkgname = pikaur
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf4a20d8ed36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Yauheni Kirylau <actionless dot loveless AT gmail.com>
+# shellcheck disable=SC2034,SC2154
+
+pkgname=pikaur
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="AUR helper with minimal dependencies. Review PKGBUILDs all in once, next build them all without user interaction."
+arch=('any')
+url="https://github.com/actionless/pikaur"
+license=('GPLv3')
+source=(
+ "$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
+)
+md5sums=(
+ "SKIP"
+)
+depends=(
+ 'pyalpm'
+ 'python-setuptools'
+ 'git'
+ 'sudo'
+ 'fakeroot'
+)
+conflicts=('pikaur-git')
+
+build() {
+ cd "${srcdir}/${pkgname}" || exit 2
+ sed -i -e "s/VERSION.*=.*/VERSION = '${pkgver}'/g" pikaur/config.py
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}" || exit 2
+ for lang in fr ru; do
+ install -Dm644 "locale/${lang}.mo" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"
+ done
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cp -r "${srcdir}/${pkgname}/packaging/"* "${pkgdir}"
+}