summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2023-05-04 13:29:03 +0200
committeractionless2023-05-04 13:29:03 +0200
commit95b070a7e2594eba5598109534602008c16a86f9 (patch)
tree8decc80c4b90ee6783c3d9bd78d8706760e8a0eb
parent628ff700570f3251fb168c55459ea77302e914c7 (diff)
downloadaur-95b070a7e2594eba5598109534602008c16a86f9.tar.gz
update to 1.15
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG23
-rw-r--r--PKGBUILD6
3 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 174bf2695eab..b1f9280e2430 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pikaur
pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
- pkgver = 1.14.7
+ pkgver = 1.15
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
@@ -17,7 +17,7 @@ pkgbase = pikaur
optdepends = python-defusedxml: securely wrap Arch news replies
provides = pikaur
conflicts = pikaur-git
- source = pikaur-1.14.7.tar.gz::https://github.com/actionless/pikaur/archive/1.14.7.tar.gz
- b2sums = fcf055ad56e3016d576c8f2b3b24db60606a2f8cfec37a1d39bddd2573dcc80e922f9f75d7ccc2c01fd22888e112f7037b3c472d4d63179332a23dc61dff2d85
+ source = pikaur-1.15.tar.gz::https://github.com/actionless/pikaur/archive/1.15.tar.gz
+ b2sums = dea8bbb9c4696ac989ca86c89aa8d3196af5011d06680c9cc924d05e955e8078a4128e634b1909931cc8a66b2af95c43ff33d9c5717b261b80945bf051df815a
pkgname = pikaur
diff --git a/CHANGELOG b/CHANGELOG
index 4cb7b1319630..64a89b2d462f 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -2029,3 +2029,26 @@ Tue Jan 3 17:22:26 2023 +0100
2022-12-26 7c5d8b7 actionless fix(config, main): create .cache dir when needed (fixes #697)
2022-12-22 375f044 actionless fix(pacman: get_pacman_test_output): results were not cached 🙀
2022-12-22 40fe015 actionless fix(core: InteractiveSpawn): dont print some cmds twice with --print-commands enabled
+
+
+Thu May 4 13:25:28 2023 +0200
+-------------------------------------------------
+1.15 Release 1.15
+
+ Notable changes:
+ * 2023-05-04 98d158f actionless fix(args: parse, reconstruct_pacman, main: cli_entry_point): read stdin when `-` supplied only for pikaur-specific commands (fixes #712)
+ * 2023-05-04 ab2c637 actionless fix(args: PikaurArgs: from_namespace): print warning about extra args only in the debug mode (fixes #709)
+ * 2023-05-01 99fa454 actionless feat(config; main: cli_entry_point): add more universal config option `DynamicUsers` instead of `AlwaysUseDynamicUsers`
+ * 2023-02-09 2a9f139 actionless fix(build: set_built_pkg_path): handle the case when package was built during this pikaur session, but build sequence was restarted (for example, due to dep-change in PKGBUILD)
+ * 2023-01-29 91e9dc3 actionless fix(TTYRestore): restore also stdout and stderr, not only stdin
+ * 2023-01-29 925b178 actionless fix(prompt): use FileLock, as threading.Lock acting weird with multithreaded TTYs
+ * 2023-01-29 aa9cf8c actionless fix(filelock): wait for lock to be available instead of raising exc, also improve logging
+ * 2023-01-29 967d3ef actionless fix(install_cli: edit_file): save/restore TTY state in case if TUI editor (like VIM) would garble the TTYs
+ * 2023-01-29 0cc77ba actionless fix(core: interactive_spawn): don't lock the logging output, as it's starting to race with input prompt lock
+ * 2023-01-28 b05e9e5 actionless feat(args, build): add --skip-aur-pull and rename --clone-concurrency to --aur-clone-concurrency
+ * 2023-01-28 e160bf8 actionless feat(install_cli: clone_repos): add new recovery option
+ * 2023-01-28 28c6dc6 actionless fix(build: clone_aur_repos): raise exception after checking all the results
+ * 2023-01-28 f0a26df actionless feat(build: clone_aur_repos): don't clone same repo twice during same pikaur session
+ * 2023-01-26 bdc01cc actionless fix(build: _set_built_package_path): regression when comparing path to str
+ * 2023-01-16 735a14a actionless fix(pkgbuild): update version regex
+ * 2023-01-12 d5b5eb8 Bundy01 chore(locale): regenerate and translate es.po, fr.po (#700)
diff --git a/PKGBUILD b/PKGBUILD
index 01d4dce4e8ab..a173f3b4c102 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.14.7
+pkgver=1.15
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -11,7 +11,7 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-b2sums=('fcf055ad56e3016d576c8f2b3b24db60606a2f8cfec37a1d39bddd2573dcc80e922f9f75d7ccc2c01fd22888e112f7037b3c472d4d63179332a23dc61dff2d85')
+b2sums=('dea8bbb9c4696ac989ca86c89aa8d3196af5011d06680c9cc924d05e955e8078a4128e634b1909931cc8a66b2af95c43ff33d9c5717b261b80945bf051df815a')
depends=(
'pyalpm'
'git'
@@ -33,7 +33,7 @@ provides=('pikaur')
build() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
- sed -i -e "s/VERSION.*=.*/VERSION = '${pkgver}'/g" pikaur/config.py
+ sed -i -e "s/^VERSION.*=.*/VERSION = '${pkgver}'/g" pikaur/config.py
if test -d ./dist ; then
rm -r ./dist
fi