summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2022-12-20 00:33:44 +0100
committeractionless2022-12-20 00:33:44 +0100
commit9b553da51e3049e04e2cdafb13b24d5a8c6e6d50 (patch)
tree082daa31a856e465113c484fa82f605920bbc021
parentcdfb6ad7b28e9e57e139c50bf6e3b49a3dd66dd4 (diff)
downloadaur-9b553da51e3049e04e2cdafb13b24d5a8c6e6d50.tar.gz
update to 1.14.6
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG19
-rw-r--r--PKGBUILD4
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63937d283817..0e4460409e08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pikaur
pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
- pkgver = 1.14.5
+ pkgver = 1.14.6
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
@@ -17,7 +17,7 @@ pkgbase = pikaur
optdepends = python-defusedxml: securely wrap Arch news replies
provides = pikaur
conflicts = pikaur-git
- source = pikaur-1.14.5.tar.gz::https://github.com/actionless/pikaur/archive/1.14.5.tar.gz
- b2sums = e944179f25d9d2da490b3c973f15ad55b9010dd461328a5ad6043e691bd6997d6b3003270e4d20c54f98c168d3632a7b7aeabbc83aa93a39614db37f5c62ec1d
+ source = pikaur-1.14.6.tar.gz::https://github.com/actionless/pikaur/archive/1.14.6.tar.gz
+ b2sums = 668f8913cc0eea6ebfa550567649d2eae90e5167a26ca4c58d8decf599aaeea3000a0440784bb02ae454182dc44790af53ccc1f445cf7c67517a632d79f51c0d
pkgname = pikaur
diff --git a/CHANGELOG b/CHANGELOG
index dd7f0d670b0e..89f982a5c55b 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -2000,3 +2000,22 @@ Tue Nov 29 04:10:58 2022 +0100
2022-11-29 f43cab0 actionless fix(pkgbuild): remove wheel after running python-installer (fixes #683)
2022-11-29 ef3a925 actionless fix(filelock: __exit__): remove the file after unlocking (fixes #685)
2022-11-29 91ba397 actionless fix(updates: print_upgradeable): `not X` vs `X is not None` ; use aur packages as input argument, as repo packages info is already cached in Pacman class anyway (fixes #687)
+
+
+Tue Dec 20 00:29:21 2022 +0100
+-------------------------------------------------
+1.14.6 Release 1.14.6
+
+ Notable changes:
+ 2022-12-19 64ac32f actionless fix(build): update spawn kwargs instead of replacing when using `--hide-build-log` flag
+ 2022-12-19 fa5c7c8 actionless fix(build: PackageBuild: init): regenerate srcinfo (fixes the case when having multiple pkgbuilds in the same directory)
+ 2022-12-19 55d27d0 actionless feat(args, help_cli): add new `--skip-failed-build` flag (similar to existing SkipFailedBuild config option)
+ 2022-12-19 f95d194 actionless feat(help_cli): document `--hide-build-log` pikaur flag
+ 2022-12-19 c561535 actionless fix(search_cli): support `--namesonly` in cases when one of search words returned expected error from aur
+ 2022-12-19 f00b99c actionless fix(args, main): `-Qu` means `--query --upgrades`, not `--query --sysupgrade`
+ 2022-12-18 8c0c83e actionless fix(makefile): throw error if can't determine path to Python (re: #695)
+ 2022-12-12 741146f actionless fix(args: get_pikaur_long_opts): include also pikaur_count_opts
+ 2022-12-10 a255eb9 actionless fix(aur: rpc_info): smarter split packages into chunks
+ 2022-12-01 04703fd actionless fix(install_info_fetcher: get_aur_pkgs_info): don't print ignored package as it's already done in a different part of the code (fixes #687)
+ 2022-11-29 40c98ca Osman Karagöz chore(locale): update TR translation (#689)
+ 2022-11-29 370a4d9 actionless fix(pkgbuild): python-installer already copying stuff from `./dist/` dir
diff --git a/PKGBUILD b/PKGBUILD
index 1e1999590f51..da942e8e1a16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.14.5
+pkgver=1.14.6
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -11,7 +11,7 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-b2sums=('e944179f25d9d2da490b3c973f15ad55b9010dd461328a5ad6043e691bd6997d6b3003270e4d20c54f98c168d3632a7b7aeabbc83aa93a39614db37f5c62ec1d')
+b2sums=('668f8913cc0eea6ebfa550567649d2eae90e5167a26ca4c58d8decf599aaeea3000a0440784bb02ae454182dc44790af53ccc1f445cf7c67517a632d79f51c0d')
depends=(
'pyalpm'
'git'