summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2022-11-26 08:38:12 +0100
committeractionless2022-11-26 08:38:12 +0100
commiteaf072967ab26a25c4433ab6e7e5936cde4a7f7c (patch)
tree926906a688884e5bd139c2e071818e8317c585b9
parentad9328b918ff41dcc742726de53b044d80a06961 (diff)
downloadaur-eaf072967ab26a25c4433ab6e7e5936cde4a7f7c.tar.gz
update to 1.14.2
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG12
-rw-r--r--PKGBUILD7
3 files changed, 20 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14f78270fe98..5c67e077f51f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pikaur
pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
- pkgver = 1.14.1
+ pkgver = 1.14.2
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
@@ -16,7 +16,7 @@ pkgbase = pikaur
optdepends = python-defusedxml: securely wrap Arch news replies
provides = pikaur
conflicts = pikaur-git
- source = pikaur-1.14.1.tar.gz::https://github.com/actionless/pikaur/archive/1.14.1.tar.gz
- b2sums = 0c5b2da2c8c6cdef3624179d9bb9dfd94b4528a3dd0b03fd181628f157ae91ee1b0848b1c9e40a95efedca06942aeee8f181dd286e1aa37dcba4c663f5c5dd75
+ source = pikaur-1.14.2.tar.gz::https://github.com/actionless/pikaur/archive/1.14.2.tar.gz
+ b2sums = 0f6e8bc0178442523004f43088c0108ca23fa4fa9be34637e680ec95035797dc66e008482c9dc74fa4f57d4e9e7b2499ff6bc2b4fe9ae9d337ad6429b33cb7ae
pkgname = pikaur
diff --git a/CHANGELOG b/CHANGELOG
index bf5112c66ac4..ecad0c9bca7d 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1960,3 +1960,15 @@ Fri Nov 25 20:57:25 2022 +0100
refactor(core: datatype): chaining classmethod descriptors (introduced in python 3.9) will be deprecated in 3.11
https://docs.python.org/3.11/whatsnew/3.11.html#language-builtins
+
+
+Sat Nov 26 08:31:02 2022 +0100
+-------------------------------------------------
+1.14.2 Release 1.14.2
+
+ Notable changes:
+ 2022-11-26 0fed425 actionless fix(pkgbuild): remove prev built wheels before building a new one
+ 2022-11-26 9c21455 actionless fix(build, config, core): remove runtime dependency on `typing_extensions`
+ 2022-11-26 2bdb925 actionless fix(pprint: create_debug_logger): use `X is not None` except of `not X`
+ 2022-11-26 a50ae21 actionless fix(main: OutputEncodingWrapper): reraise exception before stderr closes
+ 2022-11-26 a8f3af6 actionless fix(InstallInfoFetcher: get_repo_pkgs_info): correctly determine if pkg already processed
diff --git a/PKGBUILD b/PKGBUILD
index 4a63ca75138f..6fb7e8f51826 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur
-pkgver=1.14.1
+pkgver=1.14.2
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -11,7 +11,7 @@ license=('GPL3')
source=(
"$pkgname-$pkgver.tar.gz"::https://github.com/actionless/pikaur/archive/"$pkgver".tar.gz
)
-b2sums=('0c5b2da2c8c6cdef3624179d9bb9dfd94b4528a3dd0b03fd181628f157ae91ee1b0848b1c9e40a95efedca06942aeee8f181dd286e1aa37dcba4c663f5c5dd75')
+b2sums=('0f6e8bc0178442523004f43088c0108ca23fa4fa9be34637e680ec95035797dc66e008482c9dc74fa4f57d4e9e7b2499ff6bc2b4fe9ae9d337ad6429b33cb7ae')
depends=(
'pyalpm'
'git'
@@ -33,6 +33,9 @@ provides=('pikaur')
build() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 2
sed -i -e "s/VERSION.*=.*/VERSION = '${pkgver}'/g" pikaur/config.py
+ if test -d ./dist ; then
+ rm -r ./dist
+ fi
make
/usr/bin/python3 -m build --wheel --no-isolation
}