summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2022-11-25 20:21:50 +0100
committeractionless2022-11-25 20:21:50 +0100
commit28fb5fbde6630b3c79d6b5c551f8345699016732 (patch)
tree19f4965c1322b98cadf70f0016569c46bd0a0b39
parent0c99602f7fa87c2d72f55a6c6c71e1fe903e8906 (diff)
downloadaur-28fb5fbde6630b3c79d6b5c551f8345699016732.tar.gz
update to 1.14
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG14
-rw-r--r--PKGBUILD10
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac89074c743d..30e627773767 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = pikaur-git
pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
- pkgver = 1.13.2
+ pkgver = 1.14
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
license = GPL3
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-markdown-it-py
depends = pyalpm
depends = git
optdepends = asp: for ABS support in -G/--getpkgbuild operation
optdepends = python-pysocks: for socks5 proxy support
- optdepends = python-defusedxml: wrap Arch news replies
+ optdepends = python-defusedxml: securely wrap Arch news replies
provides = pikaur
conflicts = pikaur
source = pikaur-git::git+https://github.com/actionless/pikaur.git#branch=master
diff --git a/CHANGELOG b/CHANGELOG
index 6d26a7e02dc8..6f3aa56de5b8 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1938,3 +1938,17 @@ Thu Oct 27 17:26:44 2022 +0200
Notable changes:
2022-10-27 a8afb44 actionless fix(pikaur: pacman: get_print_format_output; install_info_fetcher: get_repo_pkgs_info): still check deps when needed (re: #665, #656)
2022-10-27 feb6347 actionless fix(install_info_fetcher; update: print_upgradeable): don't fetch update info twice when printing ignored packages
+
+
+Fri Nov 25 20:21:19 2022 +0100
+-------------------------------------------------
+1.14 Relase 1.14
+
+ Notable changes:
+ 2022-11-25 a8cc477 actionless fix(build): always remove installed build deps when build fails also improve exception types being raised
+ 2022-11-25 02ace37 actionless feat(pkg_cache_cli): improve message when removing cache
+ 2022-11-24 1b50155 actionless feat(urllib: read_bytes_from_url, read_gzip_from_url): a bit more sane behavior with --noconfirm flag
+ 2022-11-24 49d77a8 actionless feat(pkg_cache_cli): improve message when cache dir is already empty
+ 2022-11-24 3a28899 actionless feat(main: cli_clean_pkg_cache): when running `-Scc --noconfirm` always default everything to yes
+ 2022-11-24 f220c6a actionless fix(install_info_fetcher: _get_install_pkgs_info): correctly ask user to continue
+ 2022-11-10 933f2b0 Bundy01 chore(po): update fr and es (#674)
diff --git a/PKGBUILD b/PKGBUILD
index 966dc97d7ec0..8950140440b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur-git
-pkgver=1.13.2
+pkgver=1.14
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -19,12 +19,15 @@ depends=(
'git'
)
makedepends=(
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
'python-markdown-it-py'
)
optdepends=(
'asp: for ABS support in -G/--getpkgbuild operation'
'python-pysocks: for socks5 proxy support'
- 'python-defusedxml: wrap Arch news replies'
+ 'python-defusedxml: securely wrap Arch news replies'
)
conflicts=('pikaur')
provides=('pikaur')
@@ -39,11 +42,12 @@ build() {
cd "${srcdir}/${pkgname}" || exit 2
sed -i -e "s/VERSION.*=.*/VERSION = '${pkgver}'/g" pikaur/config.py
make
+ /usr/bin/python3 -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${pkgname}" || exit 2
- /usr/bin/python3 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ /usr/bin/python3 -m installer --destdir="$pkgdir" dist/*.whl
for langmo in $(cd ./locale && ls ./*.mo); do
lang=$(sed -e 's/.mo$//' <<< "${langmo}")
install -Dm644 "locale/${langmo}" "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/pikaur.mo"