summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2022-11-26 08:37:57 +0100
committeractionless2022-11-26 08:37:57 +0100
commitc3d627ea38e4ef76e0ff50e6d5b709c729dae20c (patch)
treef99d2d6de5ca5f75115fb9d838f8611dca790a25
parent719da14317c9b4143a7c94776ae2a1942a7c1e8a (diff)
downloadaur-c3d627ea38e4ef76e0ff50e6d5b709c729dae20c.tar.gz
update to 1.14.2
-rw-r--r--.SRCINFO2
-rw-r--r--CHANGELOG12
-rw-r--r--PKGBUILD5
3 files changed, 17 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e88c06179294..11ee812a121d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pikaur-git
pkgdesc = AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay.
- pkgver = 1.14.1
+ pkgver = 1.14.2
pkgrel = 1
url = https://github.com/actionless/pikaur
arch = any
diff --git a/CHANGELOG b/CHANGELOG
index bf5112c66ac4..ecad0c9bca7d 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1960,3 +1960,15 @@ Fri Nov 25 20:57:25 2022 +0100
refactor(core: datatype): chaining classmethod descriptors (introduced in python 3.9) will be deprecated in 3.11
https://docs.python.org/3.11/whatsnew/3.11.html#language-builtins
+
+
+Sat Nov 26 08:31:02 2022 +0100
+-------------------------------------------------
+1.14.2 Release 1.14.2
+
+ Notable changes:
+ 2022-11-26 0fed425 actionless fix(pkgbuild): remove prev built wheels before building a new one
+ 2022-11-26 9c21455 actionless fix(build, config, core): remove runtime dependency on `typing_extensions`
+ 2022-11-26 2bdb925 actionless fix(pprint: create_debug_logger): use `X is not None` except of `not X`
+ 2022-11-26 a50ae21 actionless fix(main: OutputEncodingWrapper): reraise exception before stderr closes
+ 2022-11-26 a8f3af6 actionless fix(InstallInfoFetcher: get_repo_pkgs_info): correctly determine if pkg already processed
diff --git a/PKGBUILD b/PKGBUILD
index b5cf4d47953b..ab2011a7a1ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# shellcheck disable=SC2034,SC2154
pkgname=pikaur-git
-pkgver=1.14.1
+pkgver=1.14.2
pkgrel=1
pkgdesc="AUR helper which asks all questions before installing/building. Inspired by pacaur, yaourt and yay."
arch=('any')
@@ -41,6 +41,9 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname}" || exit 2
sed -i -e "s/VERSION.*=.*/VERSION = '${pkgver}'/g" pikaur/config.py
+ if test -d ./dist ; then
+ rm -r ./dist
+ fi
make
/usr/bin/python3 -m build --wheel --no-isolation
}