summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdison Ibañez2015-09-09 13:23:12 -0500
committerEdison Ibañez2015-09-09 13:23:12 -0500
commit79ff3a9e75366411ee5c31a187e787de2f17f6bf (patch)
tree7e6cb3a0f4637c73c8ad1356ec21dd2b5320790d
downloadaur-79ff3a9e75366411ee5c31a187e787de2f17f6bf.tar.gz
Initial Commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD22
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06c0c01b16ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pilas-engine
+ pkgdesc = Un motor para hacer videojuegos de manera sencilla en Python. An engine to make games in an easy way with Python.
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = http://www.pilas-engine.com.ar
+ arch = any
+ license = LGPL
+ makedepends = mercurial
+ depends = python2
+ depends = python2-setuptools
+ depends = python2-pyqt4
+ depends = box2d
+ depends = python2-pybox2d
+ depends = python2-pygame
+ conflicts = pilas-hg
+ conflicts = pilas-git,
+ conflicts = pilas-engine-git
+ source = https://github.com/hugoruscitti/pilas-engine/archive/1.1.0.zip
+ md5sums = 7803101a29aadaa28ebc18d22a6a4823
+
+pkgname = pilas-engine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d6c0cf65d19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Edison Ibañez <edison@openmailbox.org>
+
+pkgname=pilas-engine
+my_pkgname=pilas
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Un motor para hacer videojuegos de manera sencilla en Python. An engine to make games in an easy way with Python."
+arch=('any')
+depends=('python2' 'python2-setuptools' 'python2-pyqt4' 'box2d' 'python2-pybox2d' 'python2-pygame')
+makedepends=('mercurial')
+conflicts=('pilas-hg' 'pilas-git', 'pilas-engine-git')
+license=('LGPL')
+url="http://www.pilas-engine.com.ar"
+
+source=("https://github.com/hugoruscitti/${pkgname}/archive/${pkgver}.zip")
+
+package() {
+ cd $srcdir/$my_pkgname-$pkgver
+ python2 setup.py build
+ python2 setup.py install --prefix=/usr --root "${pkgdir}" || return 1
+}
+md5sums=('7803101a29aadaa28ebc18d22a6a4823')