summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Puertas2019-12-17 08:50:21 +0100
committerKevin Puertas2019-12-17 08:50:21 +0100
commitecb58b064aa19da96dc3ad9ed2c11c506a5c1edb (patch)
treeecd43e6c14bbd6290bc5c8f49fc7b34874ec1b08
parent7e72de7635d5104a125aea453e0808f47105e7aa (diff)
downloadaur-ecb58b064aa19da96dc3ad9ed2c11c506a5c1edb.tar.gz
Update things..
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c6eb1cc7697..a408fe20422e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = piler
pkgdesc = Open source email archiving solution with all the necessary features for your enterprise
- pkgver = 1.1.1
+ pkgver = 1.3.7
pkgrel = 1
url = http://www.mailpiler.org/
arch = i686
@@ -13,19 +13,19 @@ pkgbase = piler
makedepends = tnef
depends = tre
depends = libzip
- depends = libmariadbclient
+ depends = mariadb-libs
optdepends = sphinx: for indexing emails
optdepends = poppler: for reading attachments
optdepends = catdoc: for reading attachments
optdepends = unrtf: for reading attachments
optdepends = tnef: for reading attachments
options = !emptydirs
- backup = etc/piler.conf
- source = https://bitbucket.org/jsuto/piler/downloads/piler-1.1.1.tar.gz
+ backup = etc/piler/piler.conf
+ source = https://bitbucket.org/jsuto/piler/downloads/piler-1.3.7.tar.gz
source = piler.service
source = piler-user.conf
source = piler-tmpfile.conf
- sha256sums = 41555e208fec4a979e7429687b980e69b88065dd020791dd6682dc16336947b7
+ sha256sums = 21c0db70827b2bf6b6c9c5b467f748ea90adf7b4c2c38408edeee331e101925e
sha256sums = a552d39f949888d14106b64946e20d565e290d4dea93a2562f2a0644ae2a92d6
sha256sums = 78e33088c1d0be9b5a04d85cdd4f593dd6c91e48b7241065e2dc7ee15d8c0a64
sha256sums = 40fd91c33118d6104c721db5efa4ab5cc577aa8e3311648fb1c10a6d49678d3e
diff --git a/PKGBUILD b/PKGBUILD
index a6c09769b81e..acd12c65c57c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
+# Maintainer: Kevin Puertas <kevinpr@jkanetwork.com>
# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
pkgname=piler
-pkgver=1.1.1
+pkgver=1.3.7
pkgrel=1
pkgdesc="Open source email archiving solution with all the necessary features for your enterprise"
arch=('i686' 'x86_64')
url="http://www.mailpiler.org/"
license=('GPL')
-depends=('tre' 'libzip' 'libmariadbclient')
+depends=('tre' 'libzip' 'mariadb-libs')
makedepends=('mariadb' 'poppler' 'catdoc' 'unrtf' 'tnef')
optdepends=('sphinx: for indexing emails'
'poppler: for reading attachments'
@@ -19,11 +20,11 @@ source=(https://bitbucket.org/jsuto/piler/downloads/$pkgname-$pkgver.tar.gz
piler.service
piler-user.conf
piler-tmpfile.conf)
-sha256sums=('41555e208fec4a979e7429687b980e69b88065dd020791dd6682dc16336947b7'
+sha256sums=('21c0db70827b2bf6b6c9c5b467f748ea90adf7b4c2c38408edeee331e101925e'
'a552d39f949888d14106b64946e20d565e290d4dea93a2562f2a0644ae2a92d6'
'78e33088c1d0be9b5a04d85cdd4f593dd6c91e48b7241065e2dc7ee15d8c0a64'
'40fd91c33118d6104c721db5efa4ab5cc577aa8e3311648fb1c10a6d49678d3e')
-backup=('etc/piler.conf')
+backup=('etc/piler/piler.conf')
build() {
cd "$srcdir"/$pkgname-$pkgver
@@ -33,7 +34,6 @@ build() {
--sbindir=/usr/bin \
--localstatedir=/var/lib \
--libexecdir=/usr/share \
- --enable-starttls \
--with-database=mysql \
--with-piler-user=root \
# --enable-clamd \
@@ -49,14 +49,16 @@ package() {
cd "$pkgdir"
chmod -R a-s usr/bin
- chmod 644 etc/*.conf*
install -dm755 usr/share/doc/$pkgname
- mv etc/*.dist usr/share/doc/$pkgname
+ #mv etc/*.dist usr/share/doc/$pkgname
rm -rf etc/init.d
-
- sed -r 's#pidfile=.*#pidfile=/run/piler/piler.pid#' etc/piler.conf
+ cd "$pkgdir"
+ cp etc/piler/piler.conf.dist etc/piler/piler.conf
+ cp etc/piler/sphinx.conf.dist etc/piler/sphinx.conf
+ sed -r 's#pidfile=.*#pidfile=/run/piler/piler.pid#' etc/piler/piler.conf
+ chmod 644 /etc/piler/*
install -Dm644 "$srcdir"/piler.service usr/lib/systemd/system/piler.service
install -Dm644 "$srcdir"/piler-user.conf usr/lib/sysusers.d/piler.conf