summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuacrumar2020-09-14 11:56:13 +0200
committerjuacrumar2020-09-14 11:56:13 +0200
commit33f1ffb0eff855333ecca1ecf2c53138686bd052 (patch)
tree5282c6cfda48828ceb7c83a926610bc875291467
downloadaur-33f1ffb0eff855333ecca1ecf2c53138686bd052.tar.gz
initial commit v0.3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..494e86a41aff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pineappl
+ pkgdesc = PineAPPL is not an extension of APPLgrid
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://n3pdf.github.io/pineappl/
+ arch = any
+ license = GPL3
+ depends = cargo-c
+ depends = rust
+ provides = pineappl
+ source = https://github.com/N3PDF/pineappl/archive/v0.3.0.tar.gz
+ md5sums = ca5d7a4b39ed49a5d62c015d9fe75591
+
+pkgname = pineappl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34de6424f0fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Juacrumar <juacrumar at lairen dot eu>
+
+pkgname=pineappl
+pkgver=0.3.0
+pkgrel=1
+pkgdesc='PineAPPL is not an extension of APPLgrid'
+arch=('any')
+url="https://n3pdf.github.io/pineappl/"
+license=('GPL3')
+depends=("cargo-c"
+ "rust"
+ )
+optdepends=()
+provides=("pineappl")
+changelog=
+source=("https://github.com/N3PDF/pineappl/archive/v${pkgver}.tar.gz")
+md5sums=("ca5d7a4b39ed49a5d62c015d9fe75591")
+
+prepare() {
+ cd "$pkgname-$pkgver"
+}
+
+build() {
+ # Build the python interface
+ cd "$pkgname-$pkgver"/wrappers/python
+ python setup.py build
+ cd ../../..
+}
+
+package() {
+ # Install pineappl_capi
+ cd "$pkgname-$pkgver"/pineappl_capi
+ cargo cinstall --release --prefix=${pkgdir}/usr
+ cd ..
+ # Now install the command-line program
+ cargo install --path pineappl_cli
+ # And the python wrapper
+ cd wrappers/python
+ python setup.py install --root="${pkgdir}" --optimize=2 --skip-build
+}