summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Ong2017-06-24 12:39:31 -0400
committerJoel Ong2017-06-24 12:39:31 -0400
commita9a3bcf28b482996deabbdfec8b1cdbf03ffbe9b (patch)
tree99a4d9ad1850d9c1352a320bbcba7f2e57d074a1
downloadaur-a9a3bcf28b482996deabbdfec8b1cdbf03ffbe9b.tar.gz
MWE with no frills
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD59
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01594607fbd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pineapple
+ pkgdesc = wxWidgets frontend for Jupyter Notebook, fork of project abandoned by original author (https://nwhitehead.github.io/pineapple/)
+ pkgver = 0.8.0
+ pkgrel = 0
+ url = https://github.com/darthoctopus/pineapple/tree/thin-client
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = lessc
+ makedepends = git
+ depends = python
+ depends = wxgtk3
+ depends = webkit2gtk
+ options = !buildflags
+ source = git://github.com/darthoctopus/pineapple.git
+ sha256sums = SKIP
+
+pkgname = pineapple
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..751242b97339
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Joel Ong <joel.hp+arch at gmail dot com>
+# Originally written by Nathan Whitehead <nwhitehe at gmail dot com>
+
+_GTK3=1
+options=('!buildflags')
+_opts=(
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+)
+
+pkgname='pineapple'
+
+makedepends=('cmake' 'lessc' 'git')
+depends=('python')
+
+if (("${_GTK3}" == 0));then
+ depends+=('wxgtk2' 'webkitgtk2')
+ _opts+=(-DwxWidgets_CONFIG_OPTIONS="--toolkit=gtk2")
+else
+ _opts+=(-DwxWidgets_CONFIG_OPTIONS="--toolkit=gtk3")
+ depends+=('wxgtk3' 'webkit2gtk')
+fi
+
+pkgver=0.8.0
+pkgrel=0
+pkgdesc="wxWidgets frontend for Jupyter Notebook, fork of project abandoned by original author (https://nwhitehead.github.io/pineapple/)"
+url="https://github.com/darthoctopus/pineapple/tree/thin-client"
+arch=('i686' 'x86_64')
+license=('GPL3')
+
+source=("git://github.com/darthoctopus/pineapple.git")
+
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git checkout thin-client
+}
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git checkout thin-client > /dev/null
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ mkdir -p build
+ cd build
+ cmake .. "${_opts[@]}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build"
+ make install
+}