summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGary Wang2020-10-22 23:53:58 +0800
committerGary Wang2020-10-22 23:53:58 +0800
commit2402f299ff3a9aaa602a11e77582187df6f7ac7a (patch)
tree3ee1c1d87a15b939a9663a12568cb2982ad90069
downloadaur-2402f299ff3a9aaa602a11e77582187df6f7ac7a.tar.gz
init commit for pineapple-pictures package on AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cd336929a6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pineapple-pictures
+ pkgdesc = Yet another lightweight image viewer
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://github.com/BLumia/pineapple-pictures/
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = qt5-tools
+ makedepends = cmake
+ depends = qt5-svg
+ optdepends = kimageformats: XCF, EXR, PSD and other extra image format support
+ optdepends = qt5-imageformats: TIFF, WEBP, and other extra image formats
+ source = pineapple-pictures-0.3.3.tar.gz::https://github.com/BLumia/pineapple-pictures/archive/0.3.3.tar.gz
+ md5sums = SKIP
+
+pkgname = pineapple-pictures
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc98ed9dd337
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gary Wang <wzc782970009@gmail.com>
+
+pkgname=pineapple-pictures
+pkgver=0.3.3
+pkgrel=1
+pkgdesc='Yet another lightweight image viewer'
+arch=('x86_64')
+url='https://github.com/BLumia/pineapple-pictures/'
+license=('MIT')
+depends=(
+ 'qt5-svg'
+)
+makedepends=(
+ 'git'
+ 'qt5-tools'
+ 'cmake'
+)
+optdepends=(
+ 'kimageformats: XCF, EXR, PSD and other extra image format support'
+ 'qt5-imageformats: TIFF, WEBP, and other extra image formats'
+)
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/BLumia/pineapple-pictures/archive/${pkgver}.tar.gz"
+)
+md5sums=(
+ 'SKIP'
+)
+
+build () {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ make -C ${srcdir}/${pkgname}-${pkgver} DESTDIR="$pkgdir" install
+ cd ${srcdir}/${pkgname}-${pkgver}
+ #make INSTALL_ROOT="$pkgdir" install
+ #install -Dm755 ./ppic ${pkgdir}/usr/bin/ppic
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
+ install ./LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}