summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Grieshaber2016-02-01 09:11:14 -0600
committerWilliam Grieshaber2016-02-01 09:11:14 -0600
commite12eea86f5233afbe2fde6c333fe31743a7dad91 (patch)
treec610895ec394c01a1fddd54b95038e823d119adc
downloadaur-e12eea86f5233afbe2fde6c333fe31743a7dad91.tar.gz
Initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD40
-rw-r--r--pingendo.desktop9
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8b0d8ce1104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Mon Feb 1 15:02:01 UTC 2016
+pkgbase = pingendo
+ pkgdesc = An WYSIWYG HTML5 editor focused on Bootstrap UI
+ pkgver = 0.33.1
+ pkgrel = 1
+ url = http://pingendo.com
+ arch = i686
+ arch = x86_64
+ license = custom:pingendo
+ makedepends = unzip
+ depends = nss
+ depends = libnotify
+ depends = libxtst
+ depends = gtk2
+ depends = gcc-libs-multilib
+ depends = systemd
+ depends = alsa-lib
+ depends = gconf
+ optdepends = libnotify: Adds desktop notifications
+ options = !strip
+ source = http://pingendo.com/electron/pingendo-linux-.zip
+ source = pingendo.desktop
+ sha512sums = e3c3bf68beeb439b616f628d4eb8bba2ef19d4f8c44da9404114e621f4a4e98657b6e0008320557031287ab19c8e5b4ede00a9dfdd1d31005c8eb9ba33b99e19
+ sha512sums = f247bf6a2115ecef6e7bd10029657e6d72c5e1057cc9ea6f4a6081670e3de3ec02c574bbcc820edc88ef486f13b89ea22ed0d61479b65b07eda03af0947e39f1
+
+pkgname = pingendo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd1e6045ff32
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: William Grieshaber <me@zee.li>
+# Contributor: zertyz <zertyz@gmail.com>
+
+pkgname=pingendo
+pkgver=0.33.1
+pkgrel=1
+pkgdesc="An WYSIWYG HTML5 editor focused on Bootstrap UI"
+arch=('i686' 'x86_64')
+url="http://pingendo.com"
+license=('custom:pingendo')
+depends=('nss'
+ 'libnotify'
+ 'libxtst'
+ 'gtk2'
+ 'gcc-libs-multilib'
+ 'systemd'
+ 'alsa-lib'
+ 'gconf')
+optdepends=('libnotify: Adds desktop notifications')
+options=('!strip')
+makedepends=('unzip')
+source=("http://pingendo.com/electron/$pkgname-linux-$CARCH.zip"
+ "pingendo.desktop")
+sha512sums=('e3c3bf68beeb439b616f628d4eb8bba2ef19d4f8c44da9404114e621f4a4e98657b6e0008320557031287ab19c8e5b4ede00a9dfdd1d31005c8eb9ba33b99e19'
+ 'f247bf6a2115ecef6e7bd10029657e6d72c5e1057cc9ea6f4a6081670e3de3ec02c574bbcc820edc88ef486f13b89ea22ed0d61479b65b07eda03af0947e39f1')
+
+package() {
+ mkdir -p "$pkgdir/opt/"
+
+ if [ "$CARCH" == 'x86_64' ]; then
+ cp -a "$srcdir/Pingendo-linux-x64" "$pkgdir/opt/$pkgname"
+ install -D -m0644 "$srcdir/Pingendo-linux-x64/LICENSE" "$pkgdir/usr/share/licenses/pingendo/LICENSE"
+ elif [ "$CARCH" == 'i686' ]; then
+ cp -a "$srcdir/Pingendo-linux-ia32" "$pkgdir/opt/$pkgname"
+ install -D -m0644 "$srcdir/Pingendo-linux-ia32/LICENSE" "$pkgdir/usr/share/licenses/pingendo/LICENSE"
+ fi
+
+ chmod 755 "$pkgdir/opt/$pkgname/Pingendo"
+ install -D -m0644 "$srcdir/pingendo.desktop" "$pkgdir/usr/share/applications/pingendo.desktop"
+}
diff --git a/pingendo.desktop b/pingendo.desktop
new file mode 100644
index 000000000000..8d09c554aa53
--- /dev/null
+++ b/pingendo.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Pingendo
+Comment=An WYSIWYG HTML5 editor focused on Bootstrap UI
+Icon=/usr/share/icons/nuvola/128x128/places/folder-html.png
+Exec=/opt/pingendo/Pingendo
+Terminal=false
+Type=Application
+Categories=Application;Development;
+StartupNotify=true