summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Freyermuth2016-08-16 14:07:23 +0200
committerJulien Freyermuth2016-08-16 14:07:23 +0200
commit34832c5ee27f7df2292cf315d1a6b923ce099857 (patch)
treec7f6cd84ecd1202e8694cc470296f478776d8845
parenta4aed7e2271fabcbb84cbfd019dbf6a65a038be2 (diff)
downloadaur-34832c5ee27f7df2292cf315d1a6b923ce099857.tar.gz
Adding deamon mode, status capability
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--pingormail-0.0.1.tar.gzbin2643 -> 3297 bytes
-rw-r--r--pingormail.install5
4 files changed, 16 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c275f661b1f..5cc3b5b54ed3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# sam. août 13 09:36:30 UTC 2016
+# mar. août 16 12:06:50 UTC 2016
pkgbase = pingormail
- pkgdesc = Ping address. If no result, it send an email
+ pkgdesc = Ping or connect to address. If no result, it send an email
pkgver = 0.0.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Chipsterjulien/pingormail
install = pingormail.install
arch = any
@@ -12,7 +12,7 @@ pkgbase = pingormail
options = !strip
backup = etc/pingormail/pingormail.toml
source = pingormail-0.0.1.tar.gz
- sha512sums = 108504ed4fc3325823c215c254b58a672dde861fb8015743277f16b9da66b6db976cc61f28cdf5c4332ad93a0eca65c8668e0086173b3cdf0da039d8dad32c15
+ sha512sums = 955ee2633f63a804e76f24855dc517d24b8e08d11ef0960eb6104c6f74b7cc684a7c7df1147e7c153f7f26a24db07474ae883751c93e5e221ab604800ca384a7
pkgname = pingormail
diff --git a/PKGBUILD b/PKGBUILD
index 998b0ef2b38e..57b8d1cd787f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=pingormail
pkgver=0.0.1
-pkgrel=3
-pkgdesc="Ping address. If no result, it send an email"
+pkgrel=4
+pkgdesc="Ping or connect to address. If no result, it send an email"
arch=('any')
url="https://github.com/Chipsterjulien/pingormail"
license=('WTFPL')
@@ -72,9 +72,13 @@ package() {
install -Dm644 systemd/"$pkgname".service \
"$pkgdir"/usr/lib/systemd/system/"$pkgname".service || return 1
+ # pingormail.timer
+ install -Dm644 systemd/"$pkgname".timer \
+ "$pkgdir"/usr/lib/systemd/system/"$pkgname".timer || return 1
+
# pingormail binary
install -m755 -o root -g root -D "$srcdir"/$pkgname-$pkgver/$pkgname-$pkgver \
"$pkgdir"/usr/bin/$pkgname || return 1
}
-sha512sums=('108504ed4fc3325823c215c254b58a672dde861fb8015743277f16b9da66b6db976cc61f28cdf5c4332ad93a0eca65c8668e0086173b3cdf0da039d8dad32c15')
+sha512sums=('955ee2633f63a804e76f24855dc517d24b8e08d11ef0960eb6104c6f74b7cc684a7c7df1147e7c153f7f26a24db07474ae883751c93e5e221ab604800ca384a7')
diff --git a/pingormail-0.0.1.tar.gz b/pingormail-0.0.1.tar.gz
index e8c2eaa7a456..928da0665f42 100644
--- a/pingormail-0.0.1.tar.gz
+++ b/pingormail-0.0.1.tar.gz
Binary files differ
diff --git a/pingormail.install b/pingormail.install
index 6711dd38d42f..480521e841af 100644
--- a/pingormail.install
+++ b/pingormail.install
@@ -11,6 +11,9 @@ post_install() {
echo "Adding pingormail in systemctl if you want always use it:"
echo " systemctl enable pingormail"
echo " systemctl start pingormail"
+ echo "Adding pingormail.timer in systemctl if you want use it in onshot mode:"
+ echo " systemctl enable pingormail.timer"
+ echo " systemctl start pingormail.timer"
true
}
@@ -26,8 +29,10 @@ pre_remove() {
pkgname=pingormail
# Remove symlink in systemd
systemctl disable "$pkgname"
+ systemctl disable "$pkgname".timer
# Stop server
systemctl stop "$pkgname"
+ systemctl stop "$pkgname".timer
# Reload systemctl
systemctl daemon-reload