summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2015-06-08 13:03:02 +0300
committerOleksandr Natalenko2015-06-08 13:03:02 +0300
commitddc05db575bed2c9eb53b5e3fe8217dc41e45023 (patch)
tree25e8c1083115fe42dc663a0d2edd66702e1616b2
downloadaur-ddc05db575bed2c9eb53b5e3fe8217dc41e45023.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90b27b350f8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pingtcp
+ pkgdesc = Small utility to measure TCP handshake time (torify-friendly)
+ pkgver = 0.0.2
+ pkgrel = 2
+ url = https://github.com/LanetNetwork/pingtcp
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = cmake
+ makedepends = git
+ makedepends = make
+ depends = glibc
+ depends = gcc-libs
+ optdepends = gperftools: for libtcmalloc
+ optdepends = torsocks: for TOR support
+ source = pingtcp::git+https://github.com/LanetNetwork/pingtcp.git
+ md5sums = SKIP
+
+pkgname = pingtcp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..196464a32934
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Oleksandr Natalenko aka post-factum <oleksandr@natalenko.name>
+pkgname=pingtcp
+pkgver=0.0.2
+pkgrel=2
+pkgdesc="Small utility to measure TCP handshake time (torify-friendly)"
+url="https://github.com/LanetNetwork/pingtcp"
+arch=('i686' 'x86_64')
+license=('GPLv3')
+depends=('glibc' 'gcc-libs')
+optdepends=('gperftools: for libtcmalloc' 'torsocks: for TOR support')
+makedepends=('cmake' 'git' 'make')
+source=(${pkgname}::git+https://github.com/LanetNetwork/pingtcp.git)
+
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${pkgname}
+ git submodule init
+ git submodule update
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
+ # Detect CPUs count automatically
+ CPUS_COUNT=$(nproc)
+ echo "Compiling using $CPUS_COUNT thread(s)"
+ make -j$CPUS_COUNT
+}
+
+package() {
+ cd ${srcdir}/${pkgname}/build
+ make install
+}
+