summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-11-10 22:24:03 +0100
committerCarsten Teibes2014-11-10 22:24:03 +0100
commit40191ab07580567a8dd90277808e3532049ba638 (patch)
treed6c3d6079679291f6010c06d618243750d2ad9af
downloadaur-40191ab07580567a8dd90277808e3532049ba638.tar.gz
[add] pingus-git
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD44
-rw-r--r--pingus.desktop8
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac7ac90e5ea7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = pingus-git
+ pkgdesc = A Lemmings clone, i.e. a level-based puzzle game (development version)
+ pkgver = 0.7.6.r80.g6a1153a
+ pkgrel = 1
+ url = http://pingus.seul.org
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = scons
+ makedepends = coreutils
+ makedepends = boost
+ makedepends = mesa
+ makedepends = glu
+ depends = sdl_image
+ depends = sdl_mixer
+ depends = libgl
+ depends = boost-libs
+ depends = libpng
+ optdepends = cwiid: to play with your wiimote (requires rebuild)
+ source = git+https://code.google.com/p/pingus/
+ source = pingus.desktop
+ sha256sums = SKIP
+ sha256sums = c00aef6d6f95449955e1367a5912e211f09dc345bb154084d0f13137e2089dce
+
+pkgname = pingus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96d7317f6338
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Eric Belanger <eric@archlinux.org>
+
+pkgname=pingus-git
+pkgver=0.7.6.r80.g6a1153a
+pkgrel=1
+pkgdesc="A Lemmings clone, i.e. a level-based puzzle game (development version)"
+arch=('i686' 'x86_64')
+url="http://pingus.seul.org"
+license=('GPL')
+depends=('sdl_image' 'sdl_mixer' 'libgl' 'boost-libs' 'libpng')
+makedepends=('git' 'scons' 'coreutils' 'boost' 'mesa' 'glu')
+optdepends=("cwiid: to play with your wiimote (requires rebuild)")
+source=("git+https://code.google.com/p/pingus/"
+ "pingus.desktop")
+sha256sums=('SKIP'
+ 'c00aef6d6f95449955e1367a5912e211f09dc345bb154084d0f13137e2089dce')
+
+pkgver() {
+ cd pingus
+
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+prepare() {
+ # manpage must be in man6, not man1
+ sed "s|/man1/|/man6/|g" -i pingus/Makefile
+}
+
+build() {
+ cd pingus
+
+ # add our build flags... yes, this looks ugly :/
+ scons CPPFLAGS="\"$CPPFLAGS\"" CXXFLAGS="\"$CXXFLAGS\"" LINKFLAGS="\"$LDFLAGS\"" -j$(nproc)
+}
+
+package() {
+ cd pingus
+
+ make install DESTDIR="$pkgdir/" PREFIX="/usr"
+ # .desktop entry
+ install -Dm644 ../pingus.desktop "$pkgdir"/usr/share/applications/pingus.desktop
+ install -Dm644 data/images/core/editor/actions.png "$pkgdir"/usr/share/pixmaps/pingus.png
+}
diff --git a/pingus.desktop b/pingus.desktop
new file mode 100644
index 000000000000..a3735101f0a8
--- /dev/null
+++ b/pingus.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Pingus
+Exec=pingus
+Icon=pingus
+Comment=A free Lemmings[tm] clone
+Categories=Game;LogicGame;
+Terminal=false