summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Werner Rau2024-01-31 10:00:19 +0100
committerChris Werner Rau2024-01-31 10:00:19 +0100
commit7c9b010ea1d41b54adafa6c0fd1f97bf03b9c3d7 (patch)
tree0b071cf40c7659ab994ef164b9f6cf50ddbbdc81
parente29d8dc400dd2a07fee4b8d7724992bfd7ffe46c (diff)
downloadaur-7c9b010ea1d41b54adafa6c0fd1f97bf03b9c3d7.tar.gz
Version Bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 862c32879778..5480a0ff5853 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = pinniped-bin
pkgdesc = Pinniped provides identity services for Kubernetes clusters
- pkgver = 0.25.0
+ pkgver = 0.28.0
pkgrel = 0
url = https://github.com/vmware-tanzu/pinniped
arch = x86_64
license = APACHE
conflicts = pinniped
conflicts = pinniped-git
- source = pinniped-0.25.0::https://github.com/vmware-tanzu/pinniped/releases/download/v0.25.0/pinniped-cli-linux-amd64
- sha512sums = a47f1dbce7122650b77bd53deb48c7722db329ddb25df406849ebec17bcaf402c48f14882af8a692c40ee0381df7d71ac6369214101da21cda3107ea66170aee
+ source = pinniped-0.28.0::https://github.com/vmware-tanzu/pinniped/releases/download/v0.28.0/pinniped-cli-linux-amd64
+ sha512sums = 1897557c574f071e095913c7bf9216f801e9b4c7c793c38f33e4bb9ff987cbe86df4e2d106bcafecb899ff1a7fe03ec0cdfb9d78583666bca08a1156292c8137
pkgname = pinniped-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1d316e4d4a9b..a78925c0600e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,22 @@
_pkgname=pinniped
pkgname=$_pkgname-bin
-pkgver=0.25.0
+pkgver=0.28.0
pkgrel=0
pkgdesc="Pinniped provides identity services for Kubernetes clusters"
url="https://github.com/vmware-tanzu/$_pkgname"
license=('APACHE')
source=("$_pkgname-$pkgver::$url/releases/download/v$pkgver/$_pkgname-cli-linux-amd64")
arch=('x86_64')
-sha512sums=('a47f1dbce7122650b77bd53deb48c7722db329ddb25df406849ebec17bcaf402c48f14882af8a692c40ee0381df7d71ac6369214101da21cda3107ea66170aee')
+sha512sums=('1897557c574f071e095913c7bf9216f801e9b4c7c793c38f33e4bb9ff987cbe86df4e2d106bcafecb899ff1a7fe03ec0cdfb9d78583666bca08a1156292c8137')
conflicts=("$_pkgname" "${_pkgname}-git")
package() {
install -D -m 0755 $srcdir/$_pkgname-$pkgver $pkgdir/usr/bin/$_pkgname
+ $pkgdir/usr/bin/$_pkgname completion zsh > $srcdir/zsh_$_pkgname
+ $pkgdir/usr/bin/$_pkgname completion bash > $srcdir/bash_$_pkgname
+ install -D -m 0644 $srcdir/zsh_$_pkgname $pkgdir/usr/share/zsh/site-functions/_$_pkgname
+ install -D -m 0644 $srcdir/bash_$_pkgname $pkgdir/usr/share/bash-completion/completions/$_pkgname
}
#vim: syntax=sh