summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2018-12-22 23:14:12 +0100
committerGuilhem Saurel2018-12-22 23:14:12 +0100
commit28b4db35a2cd5c6f6ebd2a68600108cf270d95f8 (patch)
tree3155d0dd092ab597db6d18ec86c636df313bafcf
parent20fd615512a06e98dbc907c6fb906a2906998a2b (diff)
downloadaur-28b4db35a2cd5c6f6ebd2a68600108cf270d95f8.tar.gz
Release v2.0.0-alpha
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 22 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02d8e8c2eed8..2b3984f49968 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = pinocchio
pkgdesc = Dynamic computations using Spatial Algebra
- pkgver = 1.2.4
- pkgrel = 2
- url = https://stack-of-tasks.github.io/pinocchio/
+ pkgver = 2.0.0_alpha
+ pkgrel = 1
+ url = https://github.com/stack-of-tasks/pinocchio/
arch = i686
arch = x86_64
license = LGPL3
@@ -12,9 +12,11 @@ pkgbase = pinocchio
depends = eigenpy
depends = urdfdom
optdepends = metapod-git
- optdepends = lua51
- source = https://github.com/stack-of-tasks/pinocchio/releases/download/v1.2.4/pinocchio-1.2.4.tar.gz
- md5sums = 5415e1514a899905f0357bf8ef6ac69f
+ optdepends = lua52
+ optdepends = cppad
+ optdepends = cppadcodegen
+ source = https://github.com/stack-of-tasks/pinocchio//releases/download/v2.0.0-alpha/pinocchio-2.0.0-alpha.tar.gz
+ sha1sums = 618de8a439e3cdc482680269f0b0e30147ace01b
pkgname = pinocchio
diff --git a/PKGBUILD b/PKGBUILD
index a9fed54687c3..96a5ae90aef7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,31 @@
# Maintainer: Guilhem Saurel <saurel@laas.fr>
+pkgorg=stack-of-tasks
pkgname=pinocchio
-pkgver=1.2.4
-pkgrel=2
+_pkgver=2.0.0-alpha
+pkgver=2.0.0_alpha
+pkgrel=1
pkgdesc="Dynamic computations using Spatial Algebra"
arch=('i686' 'x86_64')
-url="https://stack-of-tasks.github.io/pinocchio/"
+url="https://github.com/$pkgorg/$pkgname/"
license=('LGPL3')
depends=('eigen' 'hpp-fcl' 'eigenpy' 'urdfdom')
-optdepends=('metapod-git' 'lua51')
+optdepends=('metapod-git' 'lua52' 'cppad' 'cppadcodegen')
makedepends=('cmake')
-source=("https://github.com/stack-of-tasks/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('5415e1514a899905f0357bf8ef6ac69f')
+source=("$url/releases/download/v$_pkgver/$pkgname-$_pkgver.tar.gz")
+sha1sums=('618de8a439e3cdc482680269f0b0e30147ace01b')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$_pkgver-dirty"
+
+ # use python3
+ sed -i 's/BOOST_OPTIONAL_COMPONENTS} python/BOOST_OPTIONAL_COMPONENTS} python3'/ CMakeLists.txt
+
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$_pkgver-dirty"
make DESTDIR="$pkgdir/" install
}