summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2023-05-03 17:07:35 +0200
committerGuilhem Saurel2023-05-03 17:07:35 +0200
commitaafcb28e0e5cdb9f6e30bc4c689313cfda20c6d7 (patch)
tree59ab2f2c45913b4db0815e07f01bc311144a4927
parentd530e1edc5a4b293a249c5486513c10bf925b7c4 (diff)
downloadaur-aafcb28e0e5cdb9f6e30bc4c689313cfda20c6d7.tar.gz
v2.6.18
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b2eb539c6e4..c09f55b474f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pinocchio
pkgdesc = Dynamic computations using Spatial Algebra
- pkgver = 2.6.17
+ pkgver = 2.6.18
pkgrel = 1
url = https://github.com/stack-of-tasks/pinocchio
arch = i686
@@ -15,11 +15,13 @@ pkgbase = pinocchio
optdepends = lua52
optdepends = cppad
optdepends = cppadcodegen
- source = https://github.com/stack-of-tasks/pinocchio/releases/download/v2.6.17/pinocchio-2.6.17.tar.gz
- source = https://github.com/stack-of-tasks/pinocchio/releases/download/v2.6.17/pinocchio-2.6.17.tar.gz.sig
+ source = https://github.com/stack-of-tasks/pinocchio/releases/download/v2.6.18/pinocchio-2.6.18.tar.gz
+ source = https://github.com/stack-of-tasks/pinocchio/releases/download/v2.6.18/pinocchio-2.6.18.tar.gz.sig
+ source = https://github.com/stack-of-tasks/pinocchio/pull/1949.patch
validpgpkeys = A031AD35058955293D54DECEC45D22EF408328AD
- sha256sums = 42ae1e89e69519aebd3eb391fbc6d24103fc5094ba03914a8f47cfcbed556975
+ sha256sums = c497db0c7f31e7302d73efdcdc5f2834c76d25944b53d70a909991f4a2052c08
sha256sums = SKIP
+ sha256sums = 715a3c8152b5a1d2e3ad6d772024ac59be94151f39bb463d4ec5f213023bce86
pkgname = pinocchio
diff --git a/PKGBUILD b/PKGBUILD
index c4c745130f22..628ad707723a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgorg='stack-of-tasks'
_pkgname='pinocchio'
pkgname=("$_pkgname" "$_pkgname-docs")
-pkgver=2.6.17
+pkgver=2.6.18
pkgrel=1
pkgdesc="Dynamic computations using Spatial Algebra"
arch=('i686' 'x86_64')
@@ -12,11 +12,16 @@ license=('BSD')
depends=('hpp-fcl' 'eigenpy' 'urdfdom')
optdepends=('doxygen' 'lua52' 'cppad' 'cppadcodegen')
makedepends=('cmake' 'eigen')
-source=($url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz{,.sig})
-sha256sums=('42ae1e89e69519aebd3eb391fbc6d24103fc5094ba03914a8f47cfcbed556975'
- 'SKIP')
+source=($url/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz{,.sig} $url/pull/1949.patch)
+sha256sums=('c497db0c7f31e7302d73efdcdc5f2834c76d25944b53d70a909991f4a2052c08'
+ 'SKIP'
+ '715a3c8152b5a1d2e3ad6d772024ac59be94151f39bb463d4ec5f213023bce86')
validpgpkeys=('A031AD35058955293D54DECEC45D22EF408328AD')
+prepare() {
+ patch -d "$pkgbase-$pkgver" -p1 -i "$srcdir/1949.patch"
+}
+
build() {
cmake -B "build-$pkgver" -S "$pkgbase-$pkgver" \
-DBUILD_WITH_COLLISION_SUPPORT=ON \
@@ -25,8 +30,10 @@ build() {
-DBUILD_WITH_AUTODIFF_SUPPORT="$(pacman -Qs cppad > /dev/null && echo -n ON || echo -n OFF)" \
-DBUILD_WITH_CODEGEN_SUPPORT="$(pacman -Qs cppadcodegen > /dev/null && echo -n ON || echo -n OFF)" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- cmake --build "build-$pkgver"
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DGENERATE_PYTHON_STUBS=ON
+ # TODO: stubs require -j1, ref https://github.com/jrl-umi3218/jrl-cmakemodules/issues/600
+ cmake --build "build-$pkgver" -j 1
}
check() {