summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-05-01 19:29:37 +0000
committerAntonio Rojas2020-05-01 19:29:37 +0000
commit9e9790758a939d92e5f0d65fa5955f22aa274ebf (patch)
treecceeeafce87e7a1143f9373a2cb3ab9d8f3e22b1
downloadaur-9e9790758a939d92e5f0d65fa5955f22aa274ebf.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
-rw-r--r--pinta.appdata.xml59
3 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d4ca194737e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pinta
+ pkgdesc = Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to GIMP for casual users
+ pkgver = 1.6
+ pkgrel = 4
+ url = https://pinta-project.com/
+ arch = any
+ license = MIT
+ makedepends = intltool
+ depends = gtk-sharp-2
+ depends = mono-addins
+ source = https://github.com/PintaProject/Pinta/releases/download/1.6/pinta-1.6.tar.gz
+ source = pinta.appdata.xml
+ sha256sums = f1ea9e95f1051b92c8d8b6f622dfb77bd26254a165a836ec179aae10eb99d881
+ sha256sums = 37132612c9bf08b95cd3ce12ec8e3e5e76511d1e7e719d1ef5ad97e41bdd74b4
+
+pkgname = pinta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e604dfadeb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Konrad <konrad AT knauber DOT name>
+
+pkgname=pinta
+pkgver=1.6
+pkgrel=4
+pkgdesc="Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to GIMP for casual users"
+arch=('any')
+url="https://pinta-project.com/"
+license=('MIT')
+depends=('gtk-sharp-2' 'mono-addins')
+makedepends=('intltool')
+source=(https://github.com/PintaProject/Pinta/releases/download/$pkgver/$pkgname-$pkgver.tar.gz
+ pinta.appdata.xml)
+sha256sums=('f1ea9e95f1051b92c8d8b6f622dfb77bd26254a165a836ec179aae10eb99d881'
+ '37132612c9bf08b95cd3ce12ec8e3e5e76511d1e7e719d1ef5ad97e41bdd74b4')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # update the project and solution files for mono4 (taken from Fedora)
+ find . -name "*.sln" -print -exec sed -i 's/Format Version 10.00/Format Version 11.00/g' {} \;
+ find . \( -name "*.csproj" -o -name "*.proj" \) -print -exec sed -i 's#ToolsVersion="3.5"#ToolsVersion="4.0"#g; s#<TargetFrameworkVersion>.*</TargetFrameworkVersion>##g; s#<PropertyGroup>#<PropertyGroup><TargetFrameworkVersion>v4.5</TargetFrameworkVersion>#g; s#Mono.Posix, Version.*"#Mono.Posix"#g' {} \;
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 ../pinta.appdata.xml "$pkgdir/usr/share/metainfo/pinta.appdata.xml"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" license-*.txt readme.md
+ rm -r "$pkgdir/usr/share/pixmaps/"
+}
diff --git a/pinta.appdata.xml b/pinta.appdata.xml
new file mode 100644
index 000000000000..595b2af7bc50
--- /dev/null
+++ b/pinta.appdata.xml
@@ -0,0 +1,59 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>pinta.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>MIT</project_license>
+ <name>Pinta</name>
+ <summary>Edit images and paint digitally</summary>
+ <description>
+ <p>
+ Pinta is a image editing, drawing and painting application with a simple
+ yet powerful interface.
+ Pinta has a wide range of drawing tools, including: freehand, rectangles,
+ circles and lines.
+ It also has over 35 effects to apply to your images, and also has the
+ ability to create unlimited layers to help organize your creativity.
+ </p>
+ </description>
+ <launchable type="desktop-id">pinta.desktop</launchable>
+ <categories>
+ <category>Graphics</category>
+ <category>2DGraphics</category>
+ <category>RasterGraphics</category>
+ <category>GTK</category>
+ </categories>
+ <keywords>
+ <keyword>draw</keyword>
+ <keyword>drawing</keyword>
+ <keyword>paint</keyword>
+ <keyword>painting</keyword>
+ <keyword>graphics</keyword>
+ <keyword>raster</keyword>
+ <keyword>2d</keyword>
+ </keywords>
+ <kudos>
+ <kudo>HiDpiIcon</kudo>
+ <kudo>HighContrast</kudo>
+ <kudo>UserDocs</kudo>
+ </kudos>
+ <screenshots>
+ <screenshot type="default">
+ <caption>Main window</caption>
+ <image>https://pinta-project.com/pintaproject/pinta/theme/images/ss1.jpg</image>
+ </screenshot>
+ </screenshots>
+ <developer_name>Jonathan Pobst</developer_name>
+ <url type="bugtracker">https://bugs.launchpad.net/pinta</url>
+ <url type="faq">https://communiroo.com/pintaproject/pinta/questions</url>
+ <url type="help">https://pinta-project.com/pintaproject/pinta/howto</url>
+ <url type="homepage">https://pinta-project.com</url>
+ <url type="translate">https://translations.launchpad.net/pinta</url>
+ <content_rating type="oars-1.0" />
+ <translation type="gettext">pinta</translation>
+ <provides>
+ <binary>pinta</binary>
+ </provides>
+ <releases>
+ <release version="1.6" date="2015-03-01"/>
+ </releases>
+</component>