summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Puertas2022-01-04 19:37:59 +0100
committerKevin Puertas2022-01-04 19:37:59 +0100
commitee46304523a3d96bf1d63e668fbc438b86433b84 (patch)
tree46e02cda0bb87965974bf22738883e5cd91989b9
parent139dd2ebb38e250fdbb336851dbcd8b6a5a4883a (diff)
downloadaur-ee46304523a3d96bf1d63e668fbc438b86433b84.tar.gz
GTK3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f884c1e210d9..7aba492f88d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = pinta-git
pkgdesc = Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to GIMP for casual users
- pkgver = r1776.73a046e
- pkgrel = 2
+ pkgver = r2403.24d7473f
+ pkgrel = 1
url = https://pinta-project.com
arch = x86_64
arch = i686
license = MIT
makedepends = git
+ makedepends = dotnet-sdk
+ makedepends = autoconf-archive
depends = mono
- depends = gtk-sharp-2
+ depends = gtk-sharp-3
depends = mono-addins
depends = yelp-tools
depends = intltool
+ depends = dotnet-runtime
provides = pinta
conflicts = pinta
options = !makeflags
@@ -19,4 +22,3 @@ pkgbase = pinta-git
md5sums = SKIP
pkgname = pinta-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e59ee4e99e76..3e69b7582029 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
#AUR Maintainter: JKA Network <contacto@jkanetwork.com>
+#AUR Maintainter: Javier Steinaker <jsteinaker@gmail.com>
pkgname=pinta-git
-pkgver=r1776.73a046e
-pkgrel=2
+pkgver=r2403.24d7473f
+pkgrel=1
pkgdesc="Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to GIMP for casual users"
arch=('x86_64' 'i686')
url="https://pinta-project.com"
license=('MIT')
-depends=('mono' 'gtk-sharp-2' 'mono-addins' 'yelp-tools' 'intltool')
-makedepends=('git')
+depends=('mono' 'gtk-sharp-3' 'mono-addins' 'yelp-tools' 'intltool' 'dotnet-runtime')
+makedepends=('git' 'dotnet-sdk' 'autoconf-archive')
provides=('pinta')
conflicts=('pinta')
options=('!makeflags')
@@ -19,6 +20,8 @@ pkgver() {
}
build() {
cd "Pinta"
+ #maxcpucount: 1 needed to build.
+ sed -i '/^PINTA_BUILD_OPTS/ s/$/ -maxcpucount:1/' Makefile.am
./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make
}