summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2022-08-13 20:28:46 +0800
committerJingbei Li2022-08-13 20:28:46 +0800
commit5862bb170f496c949f8dc28949bc74c7c4748350 (patch)
treed1742424de81b1ccbc7d65f958762f0198234d85
parentd9e07bfb801d49a566775d5ae06cfcb507c54d98 (diff)
downloadaur-5862bb170f496c949f8dc28949bc74c7c4748350.tar.gz
migrated to python3
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD10
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25eecb2ac2db..4970486ee938 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = pinyin-completion
pkgdesc = complete path name based upon the pinyin acronym of Chinese characters
- pkgver = 34.68173f0
+ pkgver = 56.5feec0b
pkgrel = 1
url = https://github.com/petronny/pinyin-completion
install = pinyin-completion.install
arch = any
license = GPL3
makedepends = git
- depends = python2
+ depends = python
source = git+https://github.com/petronny/pinyin-completion
source = pinyin-completion.install
sha256sums = SKIP
sha256sums = f6dbcc8fc15c6de71897281f1d64f05df7dfd1e5ec3b1a70bd46a4f3078f9f13
pkgname = pinyin-completion
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ac8f49ecada2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.log
+*.tar*
+*/
diff --git a/PKGBUILD b/PKGBUILD
index ea13a648759c..6fd432b37287 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: Petron <petron@archlinuxcn.org>
+# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=pinyin-completion
-pkgver=34.68173f0
+pkgver=56.5feec0b
pkgrel=1
pkgdesc="complete path name based upon the pinyin acronym of Chinese characters"
arch=('any')
url="https://github.com/petronny/pinyin-completion"
license=('GPL3')
-depends=('python2')
+depends=('python')
makedepends=('git')
source=("git+https://github.com/petronny/pinyin-completion"
"pinyin-completion.install")
@@ -21,7 +21,7 @@ pkgver() {
build() {
cd "$srcdir/$pkgname/tools"
- python2 table-generator.py > ../pinyin/pinyin_initial.py
+ python table-generator.py > ../pinyin_completion/pinyin_initial.py
}
package() {
@@ -31,5 +31,5 @@ package() {
cp -r shell "$pkgdir/usr/share/$pkgname/"
cp -r tools "$pkgdir/usr/share/$pkgname/"
- python2 setup.py install --root=$pkgdir/ --optimize=1
+ python setup.py install --root=$pkgdir/ --optimize=1
}