summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-04-16 13:21:09 +0200
committerChristopher Arndt2020-04-16 13:21:09 +0200
commit7091e2d4867273ab4d855300f910d9e40d517251 (patch)
treeb4f9ac91b1bf676fe61741a7fcdfdfe3143a8191
parente0962a96c70c92948efe0a022501bf52082dbae2 (diff)
downloadaur-7091e2d4867273ab4d855300f910d9e40d517251.tar.gz
New upstream version 5.0.0
* Install documentation and examples * Use SHA256 sources checksum
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f4d4d177a2b..6145365a5fa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = pip-tools
pkgdesc = A set of tools to keep your pinned Python dependencies fresh.
- pkgver = 4.5.1
+ pkgver = 5.0.0
pkgrel = 1
url = https://github.com/jazzband/pip-tools/
arch = any
license = BSD
depends = python-click
- depends = python-pip
+ depends = python-pip>=20.0
depends = python-six
- source = https://files.pythonhosted.org/packages/source/p/pip-tools/pip-tools-4.5.1.tar.gz
- md5sums = f2183cd9e1f91ce1b4795ec1b1cd4c67
+ source = https://files.pythonhosted.org/packages/source/p/pip-tools/pip-tools-5.0.0.tar.gz
+ sha256sums = 2045d0414e9db71c036443efa229ff1b76dfe47a3cb022d6154a1c9e207f0867
pkgname = pip-tools
diff --git a/PKGBUILD b/PKGBUILD
index f0149bcda5eb..ad0db9a2ca37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Simon Conseil <contact+aur at saimon dot org>
pkgname=pip-tools
-pkgver=4.5.1
+pkgver=5.0.0
pkgrel=1
pkgdesc="A set of tools to keep your pinned Python dependencies fresh."
arch=('any')
url="https://github.com/jazzband/pip-tools/"
license=('BSD')
-depends=('python-click' 'python-pip' 'python-six')
+depends=('python-click' 'python-pip>=20.0' 'python-six')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('f2183cd9e1f91ce1b4795ec1b1cd4c67')
+sha256sums=('2045d0414e9db71c036443efa229ff1b76dfe47a3cb022d6154a1c9e207f0867')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -22,7 +22,13 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
+ # license
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ # documentation
+ install -Dm644 CHANGELOG.md CONTRIBUTING.md README.rst \
+ -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm644 examples/* \
+ -t "$pkgdir/usr/share/doc/$pkgname/examples"
}
# vim:set ts=2 sw=2 et: