summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-04-15 19:32:22 +0200
committerChristopher Arndt2018-04-15 19:32:22 +0200
commited460dae3092adf677c542b12eeff019b2c6e5b4 (patch)
treefd813d0f7596958592c6ec7671fb6407621e2fd1
parent763842fbc339ce3826596b42cdc97a150d398f24 (diff)
downloadaur-ed460dae3092adf677c542b12eeff019b2c6e5b4.tar.gz
New upstream version; install LICENSE file from distribution
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE.txt10
-rw-r--r--PKGBUILD19
3 files changed, 14 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a328c1775e8..f074e7f1fcee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Dec 1 11:34:55 UTC 2017
pkgbase = pip-tools
pkgdesc = A set of tools to keep your pinned Python dependencies fresh.
- pkgver = 1.11.0
+ pkgver = 2.0.1
pkgrel = 1
url = https://github.com/jazzband/pip-tools/
arch = any
@@ -11,10 +9,8 @@ pkgbase = pip-tools
depends = python-first
depends = python-pip
depends = python-six
- source = https://files.pythonhosted.org/packages/source/p/pip-tools/pip-tools-1.11.0.tar.gz
- source = LICENSE.txt
- md5sums = 76ce9d0c7c1ff01405fe80b58dbd7091
- md5sums = b542fe20de254615b3ab48020bc73441
+ source = https://files.pythonhosted.org/packages/source/p/pip-tools/pip-tools-2.0.1.tar.gz
+ md5sums = bdef605665908aa3a7639425e3f93048
pkgname = pip-tools
diff --git a/LICENSE.txt b/LICENSE.txt
deleted file mode 100644
index e021942ceafb..000000000000
--- a/LICENSE.txt
+++ /dev/null
@@ -1,10 +0,0 @@
-Copyright (c) 2015, Vincent Driessen <me@nvie.com>
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
-
-1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
-
-2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index 4599737edbbb..f98f518c3556 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,27 @@
# Contributor: Simon Conseil <contact+aur at saimon dot org>
pkgname=pip-tools
-pkgver=1.11.0
+pkgver=2.0.1
pkgrel=1
pkgdesc="A set of tools to keep your pinned Python dependencies fresh."
arch=('any')
url="https://github.com/jazzband/pip-tools/"
license=('BSD')
depends=('python-click' 'python-first' 'python-pip' 'python-six')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- LICENSE.txt)
-md5sums=('76ce9d0c7c1ff01405fe80b58dbd7091'
- 'b542fe20de254615b3ab48020bc73441')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('bdef605665908aa3a7639425e3f93048')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python setup.py build
+}
package() {
cd "$srcdir/$pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1
- install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
- install -Dm644 "${srcdir}/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname"
+ python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}
# vim:set ts=2 sw=2 et: