summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2015-12-01 22:26:21 +0100
committerChristopher Arndt2015-12-01 22:26:21 +0100
commitff41b1f3baa18bad23b3f8e56a59e82131f49a71 (patch)
treeae99698319903f4d5882332debad06399b64b714
parent14b0da120cfbf4c61bf7882462020be621df709c (diff)
downloadaur-ff41b1f3baa18bad23b3f8e56a59e82131f49a71.tar.gz
Adopted package: new upstream version 1.2.0; added 'python-pip' and 'python-first' to and removed python from dependencies; added LICENSE.txt
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore7
-rw-r--r--LICENSE.txt10
-rw-r--r--PKGBUILD16
4 files changed, 35 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9929134d13f1..967d6d578ae3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = pip-tools
pkgdesc = A set of tools to keep your pinned Python dependencies fresh.
- pkgver = 0.3.6
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/nvie/pip-tools
arch = any
license = BSD
- depends = python2
- source = http://pypi.python.org/packages/source/p/pip-tools/pip-tools-0.3.6.tar.gz
- md5sums = 931183954992b1f381aaff688be6a227
+ depends = python-click
+ depends = python-six
+ source = http://pypi.python.org/packages/source/p/pip-tools/pip-tools-1.2.0.tar.gz
+ source = LICENSE.txt
+ md5sums = f1771bee558b5abd8b206fdeb1e51d69
+ md5sums = b542fe20de254615b3ab48020bc73441
pkgname = pip-tools
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..287ba4ffa674
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg
+src
+pip-tools-*.tar.gz
+pip-tools-*.pkg.tar.xz
+pip-tools-*.src.tar.gz
+.AURINFO
+
diff --git a/LICENSE.txt b/LICENSE.txt
new file mode 100644
index 000000000000..e021942ceafb
--- /dev/null
+++ b/LICENSE.txt
@@ -0,0 +1,10 @@
+Copyright (c) 2015, Vincent Driessen <me@nvie.com>
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
+
+1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
+
+2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
index fbab6c45115d..a9cbfe5ebd76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
-# Maintainer: Simon Conseil <contact+aur at saimon dot org>
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: Simon Conseil <contact+aur at saimon dot org>
+
pkgname=pip-tools
-pkgver=1.1.4
+pkgver=1.2.0
pkgrel=1
pkgdesc="A set of tools to keep your pinned Python dependencies fresh."
arch=('any')
url="https://github.com/nvie/pip-tools"
license=('BSD')
-depends=('python' 'python-click' 'python-six')
-source=("http://pypi.python.org/packages/source/p/pip-tools/$pkgname-$pkgver.tar.gz")
-md5sums=('d4c8d2d53f565768147174e39c085ebd')
+depends=('python-click' 'python-six')
+source=("http://pypi.python.org/packages/source/p/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ LICENSE.txt)
+md5sums=('f1771bee558b5abd8b206fdeb1e51d69'
+ 'b542fe20de254615b3ab48020bc73441')
package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 "${srcdir}/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname"
}
# vim:set ts=2 sw=2 et: