summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-06-13 17:02:09 +0200
committerChristopher Arndt2020-06-13 17:02:09 +0200
commit25bb64491bbb5bb8e512103ab711ad22e8390dde (patch)
tree4644f6aa1b5ad219db9878ab8caef2a9a97f3818
parent4c637d197ac4cc14e07748170fde54d9367d7251 (diff)
downloadaur-25bb64491bbb5bb8e512103ab711ad22e8390dde.tar.gz
New upstream version 1.0.0
* Add 'graphviz' to optdepends * Use SHA256 for source hash * Simplify license install command * Update git ignore file
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9b18cf91faa..c665614325df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = pipdeptree
pkgdesc = Command line utility to show dependency tree of Python packages
- pkgver = 0.13.2
- pkgrel = 2
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://github.com/naiquevin/pipdeptree
arch = any
license = MIT
depends = python-pip
- source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-0.13.2.tar.gz
- md5sums = 1af8307b8380492a51ccaed2019d8f4b
+ optdepends = graphviz: for generating graphical output
+ source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-1.0.0.tar.gz
+ sha256sums = 5fe866a38113d28d527033ececc57b8e86df86b7c29edbacb33f41ee50f75b31
pkgname = pipdeptree
diff --git a/.gitignore b/.gitignore
index 0ea6fe60909c..9c4bf7b52ea4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,7 @@ pkg/
src/
pipdeptree-*.tar.gz
pipdeptree-*.pkg.tar.xz
+pipdeptree-*.pkg.tar.zst
pipdeptree-*.src.tar.gz
.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
index be293e411964..92d348feedb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=('pipdeptree')
-pkgver=0.13.2
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
pkgdesc="Command line utility to show dependency tree of Python packages"
url="https://github.com/naiquevin/${pkgname}"
depends=('python-pip')
+optdepends=('graphviz: for generating graphical output')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('1af8307b8380492a51ccaed2019d8f4b')
+sha256sums=('5fe866a38113d28d527033ececc57b8e86df86b7c29edbacb33f41ee50f75b31')
build() {
@@ -20,8 +21,7 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --prefix=/usr --skip-build --optimize=1
- install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et: