summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-09-06 16:04:20 +0200
committerChristopher Arndt2022-09-06 16:04:20 +0200
commit3656e94834ef16b607902ebb22ceff91a83baa24 (patch)
tree7cdec8e0afb2d30063ad469e98d8591272811e74
parent4d5482015015b255cb396dbdfa6aa577cf9db79e (diff)
downloadaur-3656e94834ef16b607902ebb22ceff91a83baa24.tar.gz
New upstream version 2.3.0
Updated build dependencies and commands
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
2 files changed, 27 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fe78f3119ee..c5bbf2d3dd09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = pipdeptree
pkgdesc = Command line utility to show dependency tree of Python packages
- pkgver = 2.2.1
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/naiquevin/pipdeptree
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-hatchling
+ makedepends = python-hatch-vcs
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-pip
optdepends = graphviz: for generating graphical output
- source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-2.2.1.tar.gz
- sha256sums = 2b97d80c64d229e01ad242f14229a899263c6e8645c588ec5b054c1b81f3065d
+ source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-2.3.0.tar.gz
+ sha256sums = 93e3b2d5c7e9363b782f84610410d0824ac46a3618cb514c6ba64665df9cba27
pkgname = pipdeptree
diff --git a/PKGBUILD b/PKGBUILD
index 95631e7bd617..a5c8d0b26344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,36 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname='pipdeptree'
-pkgver=2.2.1
+pkgver=2.3.0
pkgrel=1
-pkgdesc="Command line utility to show dependency tree of Python packages"
-url="https://github.com/naiquevin/${pkgname}"
+arch=(any)
+pkgdesc='Command line utility to show dependency tree of Python packages'
+url="https://github.com/naiquevin/$pkgname"
depends=('python-pip')
+makedepends=(python-build python-hatchling python-hatch-vcs python-installer python-wheel)
optdepends=('graphviz: for generating graphical output')
-license=('MIT')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('2b97d80c64d229e01ad242f14229a899263c6e8645c588ec5b054c1b81f3065d')
+license=(MIT)
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('93e3b2d5c7e9363b782f84610410d0824ac46a3618cb514c6ba64665df9cba27')
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i -e 's|hatchling>=1\.8\.1|hatchling|' pyproject.toml
+}
+
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py build
+ cd $pkgname-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --prefix=/usr --skip-build --optimize=1
+ cd $pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
# install documentation
- install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
# install license
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}
# vim:set ts=2 sw=2 et: