summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-05-14 12:12:41 +0200
committerChristopher Arndt2018-05-14 12:12:41 +0200
commit4838272a80a11e6813709f0c1967e4235d051a56 (patch)
tree3996516b2db3ccd7ffbf76ee6eeb0c3830f8ff4d
parenta08e49fdb5ee670a83b1efe30c067eb65405a1b8 (diff)
downloadaur-4838272a80a11e6813709f0c1967e4235d051a56.tar.gz
New upstream version
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aca01d7816af..53fc27621766 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = pipdeptree
pkgdesc = Command line utility to show dependency tree of Python packages
- pkgver = 0.11.0
+ pkgver = 0.12.1
pkgrel = 1
url = https://github.com/naiquevin/pipdeptree
arch = any
license = MIT
depends = python-pip
- source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-0.11.0.tar.gz
- md5sums = 0f8d54572e9f700357e16fc994fb1b04
+ source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-0.12.1.tar.gz
+ md5sums = e8a07f98286e06e22da80b793764b239
pkgname = pipdeptree
diff --git a/PKGBUILD b/PKGBUILD
index b2189e66bc95..4ac3e3c03d94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=('pipdeptree')
-pkgver='0.11.0'
+pkgver='0.12.1'
pkgrel=1
pkgdesc="Command line utility to show dependency tree of Python packages"
url="https://github.com/naiquevin/${pkgname}"
@@ -9,12 +9,17 @@ depends=('python-pip')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('0f8d54572e9f700357e16fc994fb1b04')
+md5sums=('e8a07f98286e06e22da80b793764b239')
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --prefix=/usr --optimize=1
+ python setup.py install --root="${pkgdir}" --prefix=/usr --skip-build --optimize=1
install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
}