summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2020-12-26 20:30:52 +0100
committerChristopher Arndt2020-12-26 20:30:52 +0100
commit92bfa7b0f3c48c039b533d99ae724664a12f2c79 (patch)
treedb7280fa4895c6c2f81a9baac217d0c30fc702cf
parent25bb64491bbb5bb8e512103ab711ad22e8390dde (diff)
downloadaur-92bfa7b0f3c48c039b533d99ae724664a12f2c79.tar.gz
New upstream version
Install README.rst as documentation.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c665614325df..7c586374f074 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = pipdeptree
pkgdesc = Command line utility to show dependency tree of Python packages
- pkgver = 1.0.0
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/naiquevin/pipdeptree
arch = any
license = MIT
depends = python-pip
optdepends = graphviz: for generating graphical output
- source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-1.0.0.tar.gz
- sha256sums = 5fe866a38113d28d527033ececc57b8e86df86b7c29edbacb33f41ee50f75b31
+ source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-2.0.0.tar.gz
+ sha256sums = 44de04e0034b7d80a5071325c80c4c8f126da001225157f542f62afa79c60f8c
pkgname = pipdeptree
diff --git a/PKGBUILD b/PKGBUILD
index 92d348feedb7..20638784627d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
-pkgname=('pipdeptree')
-pkgver=1.0.0
+pkgname='pipdeptree'
+pkgver=2.0.0
pkgrel=1
pkgdesc="Command line utility to show dependency tree of Python packages"
url="https://github.com/naiquevin/${pkgname}"
@@ -10,7 +10,7 @@ optdepends=('graphviz: for generating graphical output')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('5fe866a38113d28d527033ececc57b8e86df86b7c29edbacb33f41ee50f75b31')
+sha256sums=('44de04e0034b7d80a5071325c80c4c8f126da001225157f542f62afa79c60f8c')
build() {
@@ -21,6 +21,9 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --prefix=/usr --skip-build --optimize=1
+ # install documentation
+ install -Dm644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ # install license
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}