summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-10-31 09:10:18 +0100
committerChristopher Arndt2022-10-31 09:10:18 +0100
commitec72cee053ad12e56956fae5b5919e5ce1841699 (patch)
tree390ddcbd435ce6675fa0dfe3cbfba5698888d47f
parent533947264383ad0aaa208b669ea49b3a7dcb8736 (diff)
downloadaur-ec72cee053ad12e56956fae5b5919e5ce1841699.tar.gz
New upstream version 2.3.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0de939a2f41..342f0d62e6a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pipdeptree
pkgdesc = Command line utility to show dependency tree of Python packages
- pkgver = 2.3.1
- pkgrel = 2
+ pkgver = 2.3.3
+ pkgrel = 1
url = https://github.com/naiquevin/pipdeptree
arch = any
license = MIT
@@ -12,7 +12,7 @@ pkgbase = pipdeptree
makedepends = python-wheel
depends = python-pip
optdepends = python-graphviz: for generating graphical output
- source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-2.3.1.tar.gz
- sha256sums = 30699521e1c5861b08d29d92398f67e9a5d7f613092257fff2a8bde3c948e05b
+ source = https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-2.3.3.tar.gz
+ sha256sums = 9d666f77ff1b9528d01b3d98594096484f56de70d752abe22f13e681be239bd8
pkgname = pipdeptree
diff --git a/PKGBUILD b/PKGBUILD
index 4d442a41eed0..9114a349ee13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
pkgname=pipdeptree
-pkgver=2.3.1
-pkgrel=2
+pkgver=2.3.3
+pkgrel=1
arch=(any)
pkgdesc='Command line utility to show dependency tree of Python packages'
-url="https://github.com/naiquevin/$pkgname"
+url='https://github.com/naiquevin/pipdeptree'
depends=(python-pip)
makedepends=(python-build python-hatchling python-hatch-vcs python-installer python-wheel)
optdepends=('python-graphviz: for generating graphical output')
license=(MIT)
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=('30699521e1c5861b08d29d92398f67e9a5d7f613092257fff2a8bde3c948e05b')
+sha256sums=('9d666f77ff1b9528d01b3d98594096484f56de70d752abe22f13e681be239bd8')
prepare() {
cd $pkgname-$pkgver
- sed -i -e 's|hatchling>=1\.8\.1|hatchling|' pyproject.toml
+ sed -E -i -e 's|hatchling>=[^"]+|hatchling|' pyproject.toml
}
build() {