summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrizen2020-10-30 18:44:16 +0200
committertrizen2020-10-30 18:44:16 +0200
commitd148bc7cda2d9b1ce7251cf2a1bc223db0b2c53c (patch)
tree584fdef37273ac6c794075c5bb6ff3223d9a4e23
downloadaur-d148bc7cda2d9b1ce7251cf2a1bc223db0b2c53c.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD59
2 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..beb802c5cc9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = pipe-viewer-git
+ pkgdesc = A lightweight YouTube client for Linux (CLI/GTK) (fork of straw-viewer)
+ pkgver = 0.0.1.r1.g47f284e
+ pkgrel = 1
+ url = https://github.com/trizen/pipe-viewer
+ arch = any
+ license = Artistic2.0
+ makedepends = git
+ makedepends = perl-module-build
+ depends = perl
+ depends = perl-data-dump
+ depends = perl-json
+ depends = perl-lwp-protocol-https
+ depends = perl-gtk3
+ depends = perl-libwww
+ depends = perl-file-sharedir
+ optdepends = ffmpeg: conversions and MKV merging
+ optdepends = gnome-icon-theme: icons in menus
+ optdepends = perl-json-xs: faster JSON parsing
+ optdepends = perl-lwp-useragent-cached: local cache support
+ optdepends = perl-term-readline-gnu: better STDIN support
+ optdepends = perl-unicode-linebreak: print results in a fixed-width format (-W)
+ optdepends = mpv: play videos with MPV (recommended)
+ optdepends = vlc: play videos with VLC
+ optdepends = wget: download videos with wget
+ optdepends = youtube-dl: play videos with encrypted signatures
+ source = git+https://github.com/trizen/pipe-viewer.git
+ sha256sums = SKIP
+
+pkgname = pipe-viewer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ae79b8a38a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Trizen <echo dHJpemVuQHByb3Rvbm1haWwuY29tCg== | base64 -d>
+
+_pkgname=pipe-viewer
+pkgname=pipe-viewer-git
+pkgver=0.0.1.r1.g47f284e
+pkgrel=1
+pkgdesc="A lightweight YouTube client for Linux (CLI/GTK) (fork of straw-viewer)"
+arch=('any')
+url="https://github.com/trizen/${_pkgname}"
+license=('Artistic2.0')
+makedepends=('git' 'perl-module-build')
+
+provides=()
+conflicts=()
+
+depends=('perl' 'perl-data-dump' 'perl-json' 'perl-lwp-protocol-https' 'perl-gtk3' 'perl-libwww' 'perl-file-sharedir')
+
+optdepends=(
+ 'ffmpeg: conversions and MKV merging'
+ 'gnome-icon-theme: icons in menus'
+ 'perl-json-xs: faster JSON parsing'
+ 'perl-lwp-useragent-cached: local cache support'
+ 'perl-term-readline-gnu: better STDIN support'
+ 'perl-unicode-linebreak: print results in a fixed-width format (-W)'
+ 'mpv: play videos with MPV (recommended)'
+ 'vlc: play videos with VLC'
+ 'wget: download videos with wget'
+ 'youtube-dl: play videos with encrypted signatures'
+)
+
+source=("git+https://github.com/trizen/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ /usr/bin/perl Build.PL --gtk3
+}
+
+check(){
+ cd "$_pkgname"
+ ./Build test
+}
+
+package() {
+ cd "$_pkgname"
+ ./Build install --destdir "$pkgdir" --installdirs vendor --install_path script=/usr/bin
+ rm -r "$pkgdir/usr/lib"
+
+ mkdir "$pkgdir"/usr/share/{applications,pixmaps}
+ mv "$pkgdir"/usr/share/perl5/vendor_perl/auto/share/dist/WWW-PipeViewer/gtk-pipe-viewer.desktop \
+ "$pkgdir"/usr/share/applications/gtk-pipe-viewer.desktop
+ cp "$pkgdir"/usr/share/perl5/vendor_perl/auto/share/dist/WWW-PipeViewer/icons/gtk-pipe-viewer.png \
+ "$pkgdir"/usr/share/pixmaps/gtk-pipe-viewer.png
+}