summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnish Bhatt2015-06-21 21:37:26 -0700
committerAnish Bhatt2015-06-21 21:37:26 -0700
commitc2e1616d02b3b8fcd6ee8bc617b2b3b4722c8813 (patch)
treef39a31f6f02cbdcf513ed09beb465ca20b05e9f2
downloadaur-c2e1616d02b3b8fcd6ee8bc617b2b3b4722c8813.tar.gz
Initial commit
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD104
-rw-r--r--gnupg_fix.patch19
-rw-r--r--pipelight.install33
4 files changed, 190 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1b6098cb443
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = pipelight
+ pkgdesc = A browser plugin which allows one to use windows only plugins inside Linux browser
+ pkgver = 0.2.8
+ pkgrel = 2
+ epoch = 1
+ url = https://launchpad.net/pipelight
+ install = pipelight.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = LGPL2.1
+ license = MPL
+ makedepends = cabextract
+ makedepends = xz
+ depends = wine-silverlight>=1.7.33-1
+ depends = ttf-ms-fonts
+ depends = wget
+ depends = cabextract
+ depends = unzip
+ depends = gnupg
+ depends = libsm
+ depends = libgl
+ optdepends = zenity: needed for file dialogs,
+ optdepends = kdebase-kdialog: needed for file dialogs in KDE
+ noextract = pluginloader-v0.2.8.tar.gz
+ source = https://bitbucket.org/mmueller2012/pipelight/get/v0.2.8.tar.bz2
+ source = pluginloader-v0.2.8.tar.gz::http://repos.fds-team.de/pluginloader/v0.2.8/pluginloader.tar.gz
+ source = gnupg_fix.patch
+ md5sums = 9fcbc7019a49eb0c2f613eaba0e96df6
+ md5sums = 71b595924b8c8d91c830c2a897362ad2
+ md5sums = ac561ff3cc7df2bc3805567780ed545c
+
+pkgname = pipelight
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2542f75840a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,104 @@
+# Maintainer: Anish Bhatt anish [at] gatech [dot] edu
+
+pkgname='pipelight'
+pkgver=0.2.8
+pkgrel=2
+epoch=1
+pkgdesc="A browser plugin which allows one to use windows only plugins inside Linux browser"
+url="https://launchpad.net/pipelight"
+arch=('i686' 'x86_64')
+license=('GPL2' 'LGPL2.1' 'MPL')
+
+depends=('wine-silverlight>=1.7.33-1' 'ttf-ms-fonts' 'wget' 'cabextract' 'unzip' 'gnupg')
+if [[ "$CARCH" == "x86_64" ]]; then
+ depends+=('lib32-libsm' 'lib32-libgl')
+else
+ depends+=('libsm' 'libgl')
+fi
+
+optdepends=('zenity: needed for file dialogs',
+ 'kdebase-kdialog: needed for file dialogs in KDE')
+
+# Set value to 1 if you want to compile pluginloader yourself
+_compilepluginloader=0
+
+if [[ $_compilepluginloader != 0 ]]; then
+ if [[ "$CARCH" == "x86_64" ]]; then
+ makedepends=('mingw-w64-gcc')
+ else
+ makedepends=('mingw32-gcc')
+ fi
+fi
+
+makedepends+=('cabextract' 'xz')
+
+#source=("https://bitbucket.org/mmueller2012/pipelight/get/v${pkgver%.*}-${pkgver##*.}.tar.bz2"
+# "https://launchpad.net/pipelight/trunk/0.1/+download/pluginloader-prebuilt-v${pkgver%.*}-${pkgver##*.}.tar.gz")
+source=("https://bitbucket.org/mmueller2012/pipelight/get/v${pkgver}.tar.bz2"
+ "pluginloader-v${pkgver}.tar.gz::http://repos.fds-team.de/pluginloader/v${pkgver}/pluginloader.tar.gz"
+# "pluginloader-v${pkgver}.tar.gz.sig::http://repos.fds-team.de/pluginloader/v${pkgver}/pluginloader.tar.gz.sig"
+ "gnupg_fix.patch")
+noextract=("pluginloader-v${pkgver}.tar.gz")
+
+md5sums=('9fcbc7019a49eb0c2f613eaba0e96df6'
+ '71b595924b8c8d91c830c2a897362ad2'
+# 'SKIP'
+ 'ac561ff3cc7df2bc3805567780ed545c')
+
+#validpgpkeys=(428B5197DE952586DA520298E49CC0415DC2D5CA) # Sebastian Lackner & Michael Mueller
+
+install=pipelight.install
+
+_srcdir=mmueller2012-pipelight-b7b5e5471d52/
+
+#this changes the install location for the pipelight executables
+_prefix=/usr
+
+#change this if your wine-silverlight is installed elsewhere, or if you prefer a different wine directory
+_wine=/usr
+
+prepare() {
+ pushd $_srcdir
+
+ if [[ $_compilepluginloader == 0 ]]; then
+ ln -sf ../pluginloader-v${pkgver}.tar.gz .
+ ln -sf ../pluginloader-v${pkgver}.tar.gz.sig .
+ fi
+
+ patch -p1 < ../gnupg_fix.patch
+ pushd share/
+
+ #in case you want to use 64bit wine, you would need this
+ #if [[ "$CARCH" == "x86_64" ]]; then
+ # sed -i 's|Files|Files (x86)|g' configs/pipelight*
+ # sed -i 's|Files|Files (x86)|g' install-dependency
+ #fi
+
+ popd
+ popd
+}
+
+build() {
+ pushd $_srcdir
+ if [[ $_compilepluginloader == 0 ]]; then
+ ./configure --prefix=$_prefix --wine-path=$_wine/bin/wine --gcc-runtime-dlls="" --win32-prebuilt
+ else
+ ./configure --prefix=$_prefix --wine-path=$_wine/bin/wine --gcc-runtime-dlls="" --win32-static
+ fi
+ make
+ popd
+}
+
+package() {
+ make -C $_srcdir PREFIX=$_prefix DESTDIR=$pkgdir install
+
+ #if [[ $_compilepluginloader == 0 ]]; then
+ # install -Dm644 src/windows/pluginloader.exe ${pkgdir}/$_prefix/share/pipelight/.
+ #fi
+# All plugin creation has now been moved to pipelight.install
+
+# fix man page flags
+ chmod 0644 ${pkgdir}/usr/share/man/man1/pipelight-plugin.1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnupg_fix.patch b/gnupg_fix.patch
new file mode 100644
index 000000000000..e9067b1e4693
--- /dev/null
+++ b/gnupg_fix.patch
@@ -0,0 +1,19 @@
+diff --git a/Makefile b/Makefile
+index 7a988cd..057006f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -71,12 +71,12 @@ linux: config.make
+
+ .PHONY: prebuilt32
+ prebuilt32: config.make pluginloader-$(git_commit).tar.gz pluginloader-$(git_commit).tar.gz.sig
+- $(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig"
++ $(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig" "pluginloader-$(git_commit).tar.gz"
+ tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader/pluginloader.exe src/windows/winecheck/winecheck.exe
+
+ .PHONY: prebuilt64
+ prebuilt64: config.make pluginloader-$(git_commit).tar.gz pluginloader-$(git_commit).tar.gz.sig
+- $(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig"
++ $(gpg_exec) --batch --no-default-keyring --keyring "share/sig-pluginloader.gpg" --verify "pluginloader-$(git_commit).tar.gz.sig" "pluginloader-$(git_commit).tar.gz"
+ tar -xvf "pluginloader-$(git_commit).tar.gz" src/windows/pluginloader/pluginloader64.exe src/windows/winecheck/winecheck64.exe
+
+ .PHONY: windows32
diff --git a/pipelight.install b/pipelight.install
new file mode 100644
index 000000000000..e53a87a7c3f4
--- /dev/null
+++ b/pipelight.install
@@ -0,0 +1,33 @@
+## arg 1: the new package version
+
+pre_install() {
+ echo " ## "
+ echo " ## Please remember to close firefox before installing this package, otherwise"
+ echo " ## you might be stuck with the following issue https://answers.launchpad.net/pipelight/+faq/2357"
+ echo " ## "
+}
+
+pre_upgrade() {
+ pre_install $1
+}
+
+post_install() {
+ pipelight-plugin --create-mozilla-plugins
+ pipelight-plugin --accept --enable silverlight
+ echo " >> "
+ echo " >> Please remember to change config in /usr/share/pipelight/pipelight if any of your paths are different "
+ echo " >> and you did not change these in the PKGBUILD."
+ echo " >> Location of the installer and config file is dependent on the value of _prefix in the PKGBUILD"
+ echo " >> "
+ echo " >> You also need to change the user agent string as described here https://answers.launchpad.net/pipelight/+faq/2351"
+ echo " >> otherwise netflix will detect linux and not play by default "
+ echo " >> "
+}
+
+post_upgrade() {
+ pipelight-plugin --update
+}
+
+pre_remove() {
+ pipelight-plugin --remove-mozilla-plugins
+}