summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2016-04-22 14:12:36 +0000
committerDaichi Shinozaki2016-04-22 14:12:36 +0000
commit19bef3e46148be46ca819a10a8753a8d83ed6a9f (patch)
tree0c008ee9546d91c0708fe45763362fdf1d8c6b54
downloadaur-19bef3e46148be46ca819a10a8753a8d83ed6a9f.tar.gz
Initial check-in.
-rw-r--r--.SRCINFO57
-rw-r--r--PKGBUILD150
-rw-r--r--pipelinedb-check-db-dir49
-rw-r--r--pipelinedb-run-socket.patch12
-rw-r--r--pipelinedb.install25
-rw-r--r--pipelinedb.logrotate4
-rw-r--r--pipelinedb.pam3
-rw-r--r--pipelinedb.service34
-rw-r--r--pipelinedb.service~34
9 files changed, 368 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88be963cc6b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,57 @@
+# Generated by mksrcinfo v8
+# Fri Apr 22 14:12:26 UTC 2016
+pkgbase = pipelinedb
+ pkgdesc = The streaming SQL database
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = https://www.pipelinedb.com
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = check
+ makedepends = readline
+ makedepends = tcl
+ makedepends = jade
+ depends = openssl
+ provides = postgresql
+ conflicts = postgresql
+ conflicts = postgresql-libs
+ source = https://github.com/pipelinedb/pipelinedb/archive/0.9.1.tar.gz
+ source = pipelinedb-check-db-dir
+ source = pipelinedb-run-socket.patch
+ source = pipelinedb.pam
+ source = pipelinedb.logrotate
+ source = pipelinedb.service
+ source = pipelinedb.install
+ md5sums = c29315317744cb0e6eaaea7707673264
+ md5sums = 937eec7aabce171bc9d1eab65c560bcb
+ md5sums = 75c579eed03ffb2312631f0b649175b4
+ md5sums = 96f82c38f3f540b53f3e5144900acf17
+ md5sums = d28e443f9f65a5712c52018b84e27137
+ md5sums = 5e4cee5f654fab2cebb8764a7735c5b1
+ md5sums = e28a4671fa61e5c321683679a0aecc31
+
+pkgname = pipelinedb
+ pkgdesc = A sophisticated object-relational DBMS
+ install = pipelinedb.install
+ depends = pipelinedb-libs>=0.9.1
+ depends = krb5
+ depends = libxml2
+ depends = readline>=6.0
+ depends = openssl>=1.0.0
+ depends = pam
+ optdepends = python2: for PL/Python support
+ optdepends = perl: for PL/Perl support
+ optdepends = tcl: for PL/Tcl support
+ options = staticlibs
+ backup = etc/pam.d/pipelinedb
+ backup = etc/logrotate.d/pipelinedb
+
+pkgname = pipelinedb-libs
+ pkgdesc = Libraries for use with pipelinedb
+ depends = krb5
+ depends = openssl>=1.0.0
+ depends = readline>=6.0
+ provides = pipelinedb-client
+ conflicts = pipelinedb-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..528b6266396b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,150 @@
+# Maintainer: Daichi Shinozaki <dsdseg@gmail.com>
+# Note:
+# This package is almost same as ArchLinux's official
+# PKGBUILD of Postgresql.
+# https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/postgresql
+# Just changed the name and other minor things.
+pkgbase=pipelinedb
+pkgname=('pipelinedb' 'pipelinedb-libs')
+pkgver=0.9.1
+pkgrel=1
+pkgdesc="The streaming SQL database"
+arch=('i686' 'x86_64')
+url="https://www.pipelinedb.com"
+license=('custom')
+depends=('openssl')
+makedepends=('check' 'readline' 'tcl' 'jade')
+checkdepends=()
+provides=('postgresql')
+optdepends=()
+backup=()
+options=()
+conflicts=('postgresql' 'postgresql-libs')
+install=
+source=("https://github.com/pipelinedb/pipelinedb/archive/$pkgver.tar.gz"
+ pipelinedb-check-db-dir
+ pipelinedb-run-socket.patch
+ pipelinedb.pam
+ pipelinedb.logrotate
+ pipelinedb.service
+ pipelinedb.install)
+
+md5sums=('c29315317744cb0e6eaaea7707673264'
+ '937eec7aabce171bc9d1eab65c560bcb'
+ '75c579eed03ffb2312631f0b649175b4'
+ '96f82c38f3f540b53f3e5144900acf17'
+ 'd28e443f9f65a5712c52018b84e27137'
+ '5e4cee5f654fab2cebb8764a7735c5b1'
+ 'e28a4671fa61e5c321683679a0aecc31')
+
+build() {
+ cd "pipelinedb-$pkgver"
+
+ patch -Np1 < ../pipelinedb-run-socket.patch
+
+ ./configure CFLAGS='-O2' \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share/pipelinedb \
+ --sysconfdir=/etc \
+ --with-gssapi \
+ --with-libxml \
+ --with-openssl \
+ --with-perl \
+ --with-python PYTHON=/usr/bin/python2 \
+ --with-tcl \
+ --with-pam \
+ --with-system-tzdata=/usr/share/zoneinfo \
+ --with-uuid=e2fs \
+ --enable-nls \
+ --enable-thread-safety
+
+ make
+# make world
+}
+
+package_pipelinedb-libs() {
+ pkgdesc="Libraries for use with pipelinedb"
+ depends=('krb5' 'openssl>=1.0.0' 'readline>=6.0')
+ provides=('pipelinedb-client')
+ conflicts=('pipelinedb-client')
+
+ cd "${srcdir}/pipelinedb-${pkgver}"
+
+ # install license
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/pipelinedb-libs/LICENSE"
+
+ # install libs and non-server binaries
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump src/bin/psql src/bin/scripts; do
+ make -C ${dir} DESTDIR="${pkgdir}" install
+ done
+
+ #for util in pg_config pg_dump pg_dumpall pg_restore psql clusterdb createdb createlang createuser dropdb droplang dropuser pg_isready reindexdb vacuumdb; do
+ # install -D -m644 doc/src/sgml/man1/${util}.1 "${pkgdir}"/usr/share/man/man1/${util}.1
+ #done
+
+ cd src/include
+
+ mkdir -p "${pkgdir}"/usr/include/{libpq,pipelinedb/internal/libpq}
+
+ # these headers are needed by the public headers of the interfaces
+ install -m644 pg_config.h "${pkgdir}/usr/include/"
+ install -m644 pg_config_os.h "${pkgdir}/usr/include/"
+ install -m644 pg_config_ext.h "${pkgdir}/usr/include/"
+ install -m644 postgres_ext.h "${pkgdir}/usr/include/"
+ install -m644 libpq/libpq-fs.h "${pkgdir}/usr/include/libpq/"
+ install -m644 pg_config_manual.h "${pkgdir}/usr/include/"
+
+ # these headers are needed by the not-so-public headers of the interfaces
+ install -m644 c.h "${pkgdir}/usr/include/pipelinedb/internal/"
+ install -m644 port.h "${pkgdir}/usr/include/pipelinedb/internal/"
+ install -m644 postgres_fe.h "${pkgdir}/usr/include/pipelinedb/internal/"
+ install -m644 libpq/pqcomm.h "${pkgdir}/usr/include/pipelinedb/internal/libpq/"
+}
+
+package_pipelinedb() {
+ pkgdesc="A sophisticated object-relational DBMS"
+ backup=('etc/pam.d/pipelinedb' 'etc/logrotate.d/pipelinedb')
+ depends=("pipelinedb-libs>=${pkgver}" 'krb5' 'libxml2'
+ 'readline>=6.0' 'openssl>=1.0.0' 'pam')
+ optdepends=('python2: for PL/Python support'
+ 'perl: for PL/Perl support'
+ 'tcl: for PL/Tcl support')
+ options=('staticlibs')
+ install=pipelinedb.install
+
+ cd "${srcdir}/pipelinedb-${pkgver}"
+
+ # install
+ make DESTDIR="${pkgdir}" install
+ make -C contrib DESTDIR="${pkgdir}" install
+ #make -C doc/src/sgml DESTDIR="${pkgdir}" install-man
+
+ # we don't want these, they are in the -libs package
+ for dir in src/interfaces src/bin/pg_config src/bin/pg_dump src/bin/psql src/bin/scripts; do
+ make -C ${dir} DESTDIR="${pkgdir}" uninstall
+ done
+ #for util in pg_config pg_dump pg_dumpall pg_restore psql clusterdb createdb createlang createuser dropdb droplang dropuser pg_isready reindexdb vacuumdb; do
+ # rm "${pkgdir}"/usr/share/man/man1/${util}.1
+ #done
+
+ # install license
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+
+ # clean up unneeded installed items
+ rm -rf "${pkgdir}/usr/include/pipelinedb/internal"
+ rm -rf "${pkgdir}/usr/include/libpq"
+ find "${pkgdir}/usr/include" -maxdepth 1 -type f -execdir rm {} +
+# rmdir "${pkgdir}/usr/share/doc/pipelinedb/html"
+
+ install -D -m644 "${srcdir}/pipelinedb.service" \
+ "${pkgdir}/usr/lib/systemd/system/pipelinedb.service"
+ install -D -m755 "${srcdir}/pipelinedb-check-db-dir" \
+ "${pkgdir}/usr/bin/pipelinedb-check-db-dir"
+
+ install -D -m644 "${srcdir}/pipelinedb.pam" \
+ "${pkgdir}/etc/pam.d/pipelinedb"
+
+ install -D -m644 "${srcdir}/pipelinedb.logrotate" \
+ "${pkgdir}/etc/logrotate.d/pipelinedb"
+}
diff --git a/pipelinedb-check-db-dir b/pipelinedb-check-db-dir
new file mode 100644
index 000000000000..455b22be678c
--- /dev/null
+++ b/pipelinedb-check-db-dir
@@ -0,0 +1,49 @@
+#!/bin/sh
+
+# This script verifies that the postgresql data directory has been correctly
+# initialized. We do not want to automatically initdb it, because that has
+# a risk of catastrophic failure (ie, overwriting a valuable database) in
+# corner cases, such as a remotely mounted database on a volume that's a
+# bit slow to mount. But we can at least emit a message advising newbies
+# what to do.
+
+PGDATA="$1"
+
+if [ -z "$PGDATA" ]
+then
+ echo "Usage: $0 database-path"
+ exit 1
+fi
+
+# PGMAJORVERSION is major version
+PGMAJORVERSION=9.5
+# PREVMAJORVERSION is the previous major version, e.g., 8.4, for upgrades
+PREVMAJORVERSION=9.4
+
+# Check for the PGDATA structure
+if [ -f "$PGDATA/PG_VERSION" ] && [ -d "$PGDATA/base" ]
+then
+ # Check version of existing PGDATA
+ if [ x`cat "$PGDATA/PG_VERSION"` = x"$PGMAJORVERSION" ]
+ then
+ : A-OK
+ elif [ x`cat "$PGDATA/PG_VERSION"` = x"$PREVMAJORVERSION" ]
+ then
+ echo $"An old version of the database format was found."
+ echo $"See https://wiki.archlinux.org/index.php/PostgreSQL#Upgrading_PostgreSQL"
+ exit 1
+ else
+ echo $"An old version of the database format was found."
+ echo $"You need to dump and reload before using PostgreSQL $PGMAJORVERSION."
+ echo $"See http://www.postgresql.org/docs/$PGMAJORVERSION/static/upgrading.html"
+ exit 1
+ fi
+else
+ # No existing PGDATA! Warn the user to initdb it.
+ echo $"\"$PGDATA\" is missing or empty. Use a command like"
+ echo $" su - postgres -c \"initdb --locale en_US.UTF-8 -D '$PGDATA'\""
+ echo $"with relevant options, to initialize the database cluster."
+ exit 1
+fi
+
+exit 0
diff --git a/pipelinedb-run-socket.patch b/pipelinedb-run-socket.patch
new file mode 100644
index 000000000000..b558c7b74961
--- /dev/null
+++ b/pipelinedb-run-socket.patch
@@ -0,0 +1,12 @@
+diff -Naur postgresql-9.2.0.sockets/src/include/pg_config_manual.h postgresql-9.2.0/src/include/pg_config_manual.h
+--- postgresql-9.2.0.sockets/src/include/pg_config_manual.h 2012-09-06 17:26:17.000000000 -0400
++++ postgresql-9.2.0/src/include/pg_config_manual.h 2012-09-06 18:13:18.183092471 -0400
+@@ -144,7 +144,7 @@
+ * here's where to twiddle it. You can also override this at runtime
+ * with the postmaster's -k switch.
+ */
+-#define DEFAULT_PGSOCKET_DIR "/tmp"
++#define DEFAULT_PGSOCKET_DIR "/run/postgresql"
+
+ /*
+ * The random() function is expected to yield values between 0 and
diff --git a/pipelinedb.install b/pipelinedb.install
new file mode 100644
index 000000000000..0d23d474a0c2
--- /dev/null
+++ b/pipelinedb.install
@@ -0,0 +1,25 @@
+post_install() {
+ if [ ! -d '/var/lib/postgres' ]; then
+ mkdir -p '/var/lib/postgres'
+ fi
+ if ! getent group postgres >/dev/null; then
+ groupadd -g 88 postgres
+ fi
+ if ! getent passwd postgres >/dev/null; then
+ useradd -c 'PostgreSQL user' -u 88 -g postgres -d '/var/lib/postgres' -s /bin/bash postgres
+ passwd -l postgres >/dev/null
+ fi
+ if [ ! -d '/var/lib/postgres/data' ]; then
+ mkdir -p '/var/lib/postgres/data'
+ chown postgres:postgres '/var/lib/postgres/data'
+ fi
+}
+
+post_upgrade() {
+ post_install $1
+ # FS#23858, fix postgres user shell issue
+ postgres_shell=$(getent passwd postgres | cut -d: -f7)
+ if [ "$postgres_shell" = "/sbin/nologin" ]; then
+ chsh -s /bin/bash postgres
+ fi
+}
diff --git a/pipelinedb.logrotate b/pipelinedb.logrotate
new file mode 100644
index 000000000000..9c36918be5e5
--- /dev/null
+++ b/pipelinedb.logrotate
@@ -0,0 +1,4 @@
+/var/log/postgresql.log {
+ copytruncate
+ missingok
+}
diff --git a/pipelinedb.pam b/pipelinedb.pam
new file mode 100644
index 000000000000..53724d1f86a7
--- /dev/null
+++ b/pipelinedb.pam
@@ -0,0 +1,3 @@
+auth required pam_unix.so
+account required pam_unix.so
+session required pam_unix.so
diff --git a/pipelinedb.service b/pipelinedb.service
new file mode 100644
index 000000000000..c772e8266be3
--- /dev/null
+++ b/pipelinedb.service
@@ -0,0 +1,34 @@
+[Unit]
+Description=PipelineDB database server
+After=network.target
+
+[Service]
+Type=forking
+TimeoutSec=120
+User=postgres
+Group=postgres
+
+Environment=PGROOT=/var/lib/pipelinedb
+
+SyslogIdentifier=pipelinedb
+PIDFile=/var/lib/pipelinedb/data/postmaster.pid
+RuntimeDirectory=pipelinedb
+RuntimeDirectoryMode=755
+
+ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGROOT}/data
+ExecStart= /usr/bin/pg_ctl -s -D ${PGROOT}/data start -w -t 120
+ExecReload=/usr/bin/pg_ctl -s -D ${PGROOT}/data reload
+ExecStop= /usr/bin/pg_ctl -s -D ${PGROOT}/data stop -m fast
+
+# Due to PostgreSQL's use of shared memory, OOM killer is often overzealous in
+# killing Postgres, so adjust it downward
+OOMScoreAdjust=-200
+
+# Additional security-related features
+PrivateTmp=true
+ProtectHome=true
+ProtectSystem=full
+NoNewPrivileges=true
+
+[Install]
+WantedBy=multi-user.target
diff --git a/pipelinedb.service~ b/pipelinedb.service~
new file mode 100644
index 000000000000..a2308ed494c1
--- /dev/null
+++ b/pipelinedb.service~
@@ -0,0 +1,34 @@
+[Unit]
+Description=PostgreSQL database server
+After=network.target
+
+[Service]
+Type=forking
+TimeoutSec=120
+User=postgres
+Group=postgres
+
+Environment=PGROOT=/var/lib/pipelinedb
+
+SyslogIdentifier=pipelinedb
+PIDFile=/var/lib/pipelinedb/data/postmaster.pid
+RuntimeDirectory=pipelinedb
+RuntimeDirectoryMode=755
+
+ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGROOT}/data
+ExecStart= /usr/bin/pg_ctl -s -D ${PGROOT}/data start -w -t 120
+ExecReload=/usr/bin/pg_ctl -s -D ${PGROOT}/data reload
+ExecStop= /usr/bin/pg_ctl -s -D ${PGROOT}/data stop -m fast
+
+# Due to PostgreSQL's use of shared memory, OOM killer is often overzealous in
+# killing Postgres, so adjust it downward
+OOMScoreAdjust=-200
+
+# Additional security-related features
+PrivateTmp=true
+ProtectHome=true
+ProtectSystem=full
+NoNewPrivileges=true
+
+[Install]
+WantedBy=multi-user.target