summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2016-05-17 11:35:43 +0100
committerDaichi Shinozaki2016-05-17 11:35:43 +0100
commit9c6683a395ae9de52aa09296dde2279f5c7b1a00 (patch)
treef82ea7ea833b3a614a7ee3b6ae96b21a99ffdf1e
parent064a548e6157e4c4c1d6e257e21569f8830d3c02 (diff)
downloadaur-9c6683a395ae9de52aa09296dde2279f5c7b1a00.tar.gz
Some fixes.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--pipelinedb.install8
-rw-r--r--pipelinedb.service8
4 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88be963cc6b9..ca4504f1f20f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Fri Apr 22 14:12:26 UTC 2016
+# Tue May 17 10:34:52 UTC 2016
pkgbase = pipelinedb
pkgdesc = The streaming SQL database
pkgver = 0.9.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.pipelinedb.com
+ install = pipelinedb.install
arch = i686
arch = x86_64
license = custom
@@ -28,8 +29,8 @@ pkgbase = pipelinedb
md5sums = 75c579eed03ffb2312631f0b649175b4
md5sums = 96f82c38f3f540b53f3e5144900acf17
md5sums = d28e443f9f65a5712c52018b84e27137
- md5sums = 5e4cee5f654fab2cebb8764a7735c5b1
- md5sums = e28a4671fa61e5c321683679a0aecc31
+ md5sums = b2ef9bd989cd1b9726f63fa4b8eaff9c
+ md5sums = c7f474fd3e41caa7532df3991b93f609
pkgname = pipelinedb
pkgdesc = A sophisticated object-relational DBMS
diff --git a/PKGBUILD b/PKGBUILD
index 528b6266396b..55a0f8df9d54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=pipelinedb
pkgname=('pipelinedb' 'pipelinedb-libs')
pkgver=0.9.1
-pkgrel=1
+pkgrel=2
pkgdesc="The streaming SQL database"
arch=('i686' 'x86_64')
url="https://www.pipelinedb.com"
@@ -20,10 +20,10 @@ optdepends=()
backup=()
options=()
conflicts=('postgresql' 'postgresql-libs')
-install=
+install=pipelinedb.install
source=("https://github.com/pipelinedb/pipelinedb/archive/$pkgver.tar.gz"
pipelinedb-check-db-dir
- pipelinedb-run-socket.patch
+ pipelinedb-run-socket.patch
pipelinedb.pam
pipelinedb.logrotate
pipelinedb.service
@@ -34,8 +34,8 @@ md5sums=('c29315317744cb0e6eaaea7707673264'
'75c579eed03ffb2312631f0b649175b4'
'96f82c38f3f540b53f3e5144900acf17'
'd28e443f9f65a5712c52018b84e27137'
- '5e4cee5f654fab2cebb8764a7735c5b1'
- 'e28a4671fa61e5c321683679a0aecc31')
+ 'b2ef9bd989cd1b9726f63fa4b8eaff9c'
+ 'c7f474fd3e41caa7532df3991b93f609')
build() {
cd "pipelinedb-$pkgver"
@@ -59,7 +59,8 @@ build() {
--enable-nls \
--enable-thread-safety
- make
+ make
+# Commented out. Could not build because of the sgml processing error.
# make world
}
diff --git a/pipelinedb.install b/pipelinedb.install
index 0d23d474a0c2..1b60d14a740f 100644
--- a/pipelinedb.install
+++ b/pipelinedb.install
@@ -1,6 +1,6 @@
post_install() {
- if [ ! -d '/var/lib/postgres' ]; then
- mkdir -p '/var/lib/postgres'
+ if [ ! -d '/var/lib/pipelinedb' ]; then
+ mkdir -p '/var/lib/pipelinedb'
fi
if ! getent group postgres >/dev/null; then
groupadd -g 88 postgres
@@ -9,8 +9,8 @@ post_install() {
useradd -c 'PostgreSQL user' -u 88 -g postgres -d '/var/lib/postgres' -s /bin/bash postgres
passwd -l postgres >/dev/null
fi
- if [ ! -d '/var/lib/postgres/data' ]; then
- mkdir -p '/var/lib/postgres/data'
+ if [ ! -d '/var/lib/pipelinedb/data' ]; then
+ mkdir -p '/var/lib/pipelinedb/data'
chown postgres:postgres '/var/lib/postgres/data'
fi
}
diff --git a/pipelinedb.service b/pipelinedb.service
index c772e8266be3..128a4a53a19a 100644
--- a/pipelinedb.service
+++ b/pipelinedb.service
@@ -15,10 +15,10 @@ PIDFile=/var/lib/pipelinedb/data/postmaster.pid
RuntimeDirectory=pipelinedb
RuntimeDirectoryMode=755
-ExecStartPre=/usr/bin/postgresql-check-db-dir ${PGROOT}/data
-ExecStart= /usr/bin/pg_ctl -s -D ${PGROOT}/data start -w -t 120
-ExecReload=/usr/bin/pg_ctl -s -D ${PGROOT}/data reload
-ExecStop= /usr/bin/pg_ctl -s -D ${PGROOT}/data stop -m fast
+ExecStartPre=/usr/bin/pipelinedb-check-db-dir ${PGROOT}/data
+ExecStart= /usr/bin/pipelinedb-ctl -s -D ${PGROOT}/data start -w -t 120
+ExecReload=/usr/bin/pipelinedb-ctl -s -D ${PGROOT}/data reload
+ExecStop= /usr/bin/pipelinedb-ctl -s -D ${PGROOT}/data stop -m fast
# Due to PostgreSQL's use of shared memory, OOM killer is often overzealous in
# killing Postgres, so adjust it downward