summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Fernando Zazo2019-05-16 15:01:35 +0200
committerJose Fernando Zazo2019-05-16 15:01:35 +0200
commitf12d7af93aa3ab7be8faac306744309dc1a7150e (patch)
tree36bdbe4bc7bc4f69d4c167748144604b584300c2
downloadaur-f12d7af93aa3ab7be8faac306744309dc1a7150e.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
-rw-r--r--pipelinedb-dir.patch11
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc295f3e0483
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pipelinedb
+ pkgdesc = The streaming SQL database
+ pkgver = 1.0.0
+ pkgrel = 13
+ url = https://www.pipelinedb.com
+ arch = any
+ license = Apache2
+ makedepends = zeromq
+ depends = postgresql>=10.1
+ provides = pipelinedb
+ conflicts = pipelinedb
+ source = https://github.com/pipelinedb/pipelinedb/archive/1.0.0-13.tar.gz
+ md5sums = 6902fd076cc6f0615a2d4042021d792f
+
+pkgname = pipelinedb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3de10deb8d54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Jose Fernando Zazo <josefernando.zazo@hotmail.com>
+#
+pkgname=('pipelinedb')
+pkgver='1.0.0'
+pkgrel=13
+pkgdesc="The streaming SQL database"
+arch=('any')
+url="https://www.pipelinedb.com"
+license=('Apache2')
+depends=('postgresql>=10.1')
+makedepends=('zeromq')
+provides=('pipelinedb')
+conflicts=('pipelinedb')
+source=("https://github.com/pipelinedb/pipelinedb/archive/${pkgver}-${pkgrel}.tar.gz")
+
+md5sums=('6902fd076cc6f0615a2d4042021d792f')
+
+
+prepare() {
+ patch -Np1 < ../pipelinedb-dir.patch
+}
+
+build() {
+ cd "pipelinedb-${pkgver}-${pkgrel}"
+
+ make LDFLAGS=-lzmq USE_PGXS=1
+}
+
+package() {
+ cd "${srcdir}/pipelinedb-${pkgver}-${pkgrel}"
+
+ # install
+ make DESTDIR="${pkgdir}" install
+
+ # install license
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
+
+ # clean up unneeded installed items
+ rm -rf "${pkgdir}/usr/include/pipelinedb/internal"
+ rm -rf "${pkgdir}/usr/include/libpq"
+ find "${pkgdir}/usr/include" -maxdepth 1 -type f -execdir rm {} +
+}
+
+post_install() {
+ echo "Remember to update your configuration to preload the pipelinedb extension with:"
+ echo " \$cat \"shared_preload_libraries = 'pipelinedb'\" >> /var/lib/postgres/data/postgresql.conf"
+ echo " \$cat \"max_worker_processes = 128\" >> /var/lib/postgres/data/postgresql.conf"
+ echo "And to enable the pipelinedb extension in your database with:"
+ echo " \$psql -c \"CREATE EXTENSION pipelinedb\""
+} \ No newline at end of file
diff --git a/pipelinedb-dir.patch b/pipelinedb-dir.patch
new file mode 100644
index 000000000000..0a24c1e0a64e
--- /dev/null
+++ b/pipelinedb-dir.patch
@@ -0,0 +1,11 @@
+--- src/pipelinedb-1.0.0-13/Makefile 2019-02-19 20:59:21.000000000 +0100
++++ Makefile 2019-05-14 14:34:40.957982147 +0200
+@@ -49,7 +49,7 @@
+
+ bin_dir = ./bin
+
+-headers_dir = $(shell $(PG_CONFIG) --includedir-server)/../pipelinedb
++headers_dir = $(DESTDIR)$(shell $(PG_CONFIG) --includedir-server)/../pipelinedb
+
+ # Headers for other extensions to build against
+ install-headers: