summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-08 06:55:56 -0400
committerChris Severance2015-09-08 06:55:56 -0400
commit34d13bc346955d58c436f30a4ce2a35ac5034588 (patch)
treece69234f2693da58e637175eff5e599115b21cd5
downloadaur-34d13bc346955d58c436f30a4ce2a35ac5034588.tar.gz
Initial Import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
-rw-r--r--patch14
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9679f80f61a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pipemeter
+ pkgdesc = A command line utility that displays the speed and, if possible, progress, of data moving from its input to its output.
+ pkgver = 1.1.3
+ pkgrel = 3
+ url = http://spamaps.org/pipemeter.php
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = patch
+ source = http://spamaps.org/files/pipemeter/pipemeter-1.1.3.tar.gz
+ source = patch
+ sha256sums = 1ff952cb2127476ca9879f4b28fb92d6dabb0cc02db41f657025f7782fd50aaf
+ sha256sums = 259b34d99a7c11ef073e3de00fab8c9dbbebabde3141cedb026cf9d512faab31
+
+pkgname = pipemeter
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ade53c219f87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: kfgz <kfgz at interia pl>
+# Contributor: Fernando < arch at liquuid dot net >
+# Contributor: Damir Perisa <damir dot perisa at bluewin dot ch>
+# Contributor: Nathan Owe <ndowens.aur at gmail dot com>
+
+set -u
+pkgname='pipemeter'
+pkgver='1.1.3'
+pkgrel='3'
+pkgdesc='A command line utility that displays the speed and, if possible, progress, of data moving from its input to its output.'
+arch=('i686' 'x86_64')
+url='http://spamaps.org/pipemeter.php'
+makedepends=('patch')
+license=('GPL2')
+source=("http://spamaps.org/files/pipemeter/${pkgname}-${pkgver}.tar.gz" 'patch')
+sha256sums=('1ff952cb2127476ca9879f4b28fb92d6dabb0cc02db41f657025f7782fd50aaf'
+ '259b34d99a7c11ef073e3de00fab8c9dbbebabde3141cedb026cf9d512faab31')
+
+prepare() {
+ set -u
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix='/usr'
+ patch -uN -i "${srcdir}/patch"
+ set +u
+}
+
+build() {
+ set -u
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+ set +u
+}
+
+package() {
+ set -u
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ set +u
+}
+set +u
diff --git a/patch b/patch
new file mode 100644
index 000000000000..7afcf8bae265
--- /dev/null
+++ b/patch
@@ -0,0 +1,14 @@
+--- Makefile 2010-09-15 00:08:25.350002524 -0500
++++ Makefile-new 2010-09-15 00:10:01.210002523 -0500
+@@ -24,8 +24,9 @@
+
+
+ install: pipemeter pipemeter.1
+- install -p -s pipemeter $(PREFIX)/bin
+- install -p pipemeter.1 $(PREFIX)/man/man1
++ install -d $(DESTDIR)$(PREFIX)/bin $(DESTDIR)$(PREFIX)/share/man/man1
++ install -p -s pipemeter $(DESTDIR)$(PREFIX)/bin/
++ install -p pipemeter.1 $(DESTDIR)$(PREFIX)/share/man/man1/
+
+ dist: pipemeter
+ sh pkgpipemeter.sh