summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Piribauer2018-11-04 12:54:51 +0100
committerFabian Piribauer2018-11-04 12:54:51 +0100
commit2c1f0da58eabb734e1ef1a008d50be57ead0859f (patch)
tree2a2d5cd0146dc1b242e1befa19622a674de59ec6
parent92832d7fd03293a9737ddb0c3e2fbdeb1e2a8d81 (diff)
downloadaur-2c1f0da58eabb734e1ef1a008d50be57ead0859f.tar.gz
remove install script the same way [community] does
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6070f4b9cd5e..9d91fdabc066 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = piper-git
pkgdesc = Piper is a GUI interface to ratbagd, the system daemon for configurable mice
pkgver = 0.2.902.r16.g5a44f97
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/libratbag/piper
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d9b26bd17f54..f5bd7da8bf44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=piper-git
pkgver=0.2.902.r16.g5a44f97
-pkgrel=1
+pkgrel=2
pkgdesc='Piper is a GUI interface to ratbagd, the system daemon for configurable mice'
arch=('i686' 'x86_64')
url='https://github.com/libratbag/piper'
@@ -17,6 +17,14 @@ sha256sums=('SKIP')
conflicts=('piper')
provides=('piper')
+prepare() {
+ cd "${pkgname}"
+
+ # Remove install script
+ # This is handled by pacman hooks
+ sed -i "/meson.add_install_script('meson_install.sh')/d" meson.build
+}
+
pkgver() {
cd "${pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'