summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYu-Jie Lin2018-03-29 15:50:55 +0800
committerYu-Jie Lin2018-03-29 15:53:22 +0800
commitafdf88c7c349841260943464a1ef76600c570be1 (patch)
treecc9964c95b58269d1284abc2b17404e3afd8c785
downloadaur-afdf88c7c349841260943464a1ef76600c570be1.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37624f17acb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pipes.sh
+ pkgdesc = Animated pipes terminal screensaver
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/pipeseroni/pipes.sh
+ arch = any
+ license = MIT
+ depends = bash>=4.0.0
+ source = https://github.com/pipeseroni/pipes.sh/archive/v1.3.0.tar.gz
+ md5sums = 45bc7a89750c3c9ceacd33794173ca99
+
+pkgname = pipes.sh
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4fa4a38be3e5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+
+pkg/*
+src/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e25a31230369
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: To Be Assigned <youremail@domain.com>
+pkgname=pipes.sh
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='Animated pipes terminal screensaver'
+arch=('any')
+url='https://github.com/pipeseroni/pipes.sh'
+license=('MIT')
+groups=()
+depends=('bash>=4.0.0')
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/pipeseroni/$pkgname/archive/v$pkgver.tar.gz")
+noextract=()
+md5sums=('45bc7a89750c3c9ceacd33794173ca99')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" LICENSE
+ install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" README.rst
+}