summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJavier Tiá2016-01-23 11:37:08 -0600
committerJavier Tiá2016-01-23 11:37:08 -0600
commit8ccefc43271d8083db98cc670e7c4c3ff33940f7 (patch)
treed05d07a123b57652ecf29704c44fb920156f903d
downloadaur-8ccefc43271d8083db98cc670e7c4c3ff33940f7.tar.gz
Bump up pipethis v0.1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4e19c38e41d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Jan 23 17:29:49 UTC 2016
+pkgbase = pipethis
+ pkgdesc = Replace your installers
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/ellotheth/pipethis
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = go
+ makedepends = git
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/ellotheth/pipethis/archive/v0.1.tar.gz
+ sha256sums = ca27e1a3fcf50af3737c58fdedddbeba3d5dcbfb6e2e14abdc998d2989317fa1
+
+pkgname = pipethis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c5f211acd10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Javier Tia <javier dot tia at gmail dot com>
+
+pkgname=pipethis
+pkgver=0.1
+pkgrel=1
+pkgdesc="Replace your `curl | sh` installers"
+arch=('i686' 'x86_64')
+url="https://github.com/ellotheth/pipethis"
+license=('GPL2')
+makedepends=('go' 'git')
+options=('!strip' '!emptydirs')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('ca27e1a3fcf50af3737c58fdedddbeba3d5dcbfb6e2e14abdc998d2989317fa1')
+_gourl=github.com/ellotheth/pipethis
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export GOPATH="${srcdir}"
+ go get -v ${_gourl}
+}
+
+package() {
+ install -Dm 775 "${srcdir}/bin/${pkgname}" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ft=sh ts=2 sw=2 et: